Hi again,

Well as mentioned yesterday, I couldn't let this one go by without at least trying to figure out the real reason, so I experimented somewhat further.

The issue of ssh1 vs. ssh2 appears to already be clarified, so I won't
go into it again.

Yes, indeed. I myself yesterday came to realise that I had incorrectly used the term SSH1 for password authentication, whereas it's basically just a different handshake and encryption protocol. My bad. :p

Then:

It shouldn't.  That's odd, as there's no reason to use SSH1 with FreeBSD
5.4 -- SSH2 worked just fine in 5.X.  I'd investigate your puTTY installation/
config, as it sounds to be corrupt.

Well, I did indeed run the daemon in debug mode, and from the traces I gather that the handshaking doesn't work properly. Towards the end of the traces, we find:

debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: client->server 3des-cbc hmac-sha1 none
debug1: kex: server->client 3des-cbc hmac-sha1 none
debug1: expecting SSH2_MSG_KEXDH_INIT
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
Connection closed by 192.168.1.103
debug1: do_cleanup
debug1: do_cleanup

And it never (or well, hardly ever) seems to get past that point.

I then checked if perhaps I could configure anything in PuTTY regarding the handshaking or so, and found very few options there (all yielding no better luck in connecting).

Then, I checked the PuTTY version, and found that it was "release-0.50", whereas I read you used versions 0.58 and 0.59. D/L-ed version 0.59 and that works fine!

Sooo, indeed the PuTTY installation I had was flaky. For some reason it did work fine with my FreeBSD 5.4 installation, dunno why ?!?

Good, glad this one is solved and that it turned out to be such a trivial thing!

Tnx for your help, and cheers!
Olafo
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to