new host rc.conf:

hostname="elrond.ameritech.net"
#ifconfig_nve0="inet 192.168.1.84 netmask 255.255.255.0"
ipv4_addrs_nve0="192.168.1.84-85/24 netmask 255.255.255.0"
defaultrouter="192.168.1.1"
#ifconfig_nve0="DHCP"
usbd_enable="YES"
linux_enable="YES"
sshd_enable="YES"

sendmail_enable="NO"
inetd_flags="-wW -a 192.168.1.84"
rpcbind_enable="NO"


attempts after rebooting still fail.


The jail rc.conf:
#hostname="legolas.ameritech.net"
#ifconfig_nve0="inet 192.168.1.85 netmask 255.255.255.0"
#defaultrouter="192.168.1.1"
rpcbind_enable="NO"
ifconfig_nve0=""


I have tried this with both the above setup, and one setup commenting
out the ifconfig_nve0="" line, and uncommenting the other
ifconfig_nve0/defaultrouter lines (just in case I misread something).
Neither worked.

Thanks
-Jim Stapleton



On 2/23/07, Philipp Wuensche <[EMAIL PROTECTED]> wrote:
Jim Stapleton wrote:
> Jail:
> [EMAIL PROTECTED] 14:04:11 (0) ~  > sudo jail /jail/ legolas 192.168.1.85
> /bin/csh
> %telnet 192.168.1.4 25
> Trying 192.168.1.4...
> ^Z
> Suspended
> %kill %1
> [1]    Terminated                    telnet 192.168.1.4 25
> %ifconfig -a
> nve0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>        ether 00:13:d4:2e:2f:62
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
> plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> mtu 1500
> lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
>
>
> OK, from host:
> [EMAIL PROTECTED] 14:02:11 (0) ~  > ifconfig -a
> nve0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>        inet 192.168.1.84 netmask 0xffffff00 broadcast 192.168.1.255
>        ether 00:13:d4:2e:2f:62
>        media: Ethernet autoselect (100baseTX <full-duplex>)
>        status: active
> plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> mtu 1500
> lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
>        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
>        inet6 ::1 prefixlen 128
>        inet 127.0.0.1 netmask 0xff000000
> [EMAIL PROTECTED] 14:04:08 (0) ~  > jls
>   JID  IP Address      Hostname                      Path
>     1  192.168.1.85    legolas                       /jail
>
>
>
> Is that what you needed

You only have configured the 192.168.1.84 ipaddr on your nve0 interface,
you need to configure the 192.168.1.85 ipaddr. on the interface too.

Delete the

ifconfig_nve0="inet 192.168.1.84 netmask 255.255.255.0"

line in rc.conf and replace it with

ipv4_addrs_nve0="192.168.1.84-85/24"

and do a reboot. If you don't want to reboot, use "ifconfig nve0 alias
192.168.1.85/32" to configure the alias while the system is running.

You could also use the jail_example_interface="nve0" option in rc.conf
and reboot, but I don't recommend that because it is somewhat broken and
poorly implemented.

greetings,
philipp



_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to