----- Original Message ----
From: Garrett Cooper <[EMAIL PROTECTED]>
To: freebsd-questions@freebsd.org
Sent: Thursday, March 8, 2007 11:09:13 AM
Subject: Re: Setting Env

> Well, it's going to involve a bit more than that to get an rc script up 
> and running I'm afraid.. the script needs a start, stop, status 
> functions, as well as a few others. Some examples are in the /etc/rc.d 
> and /usr/local/etc/rc.d directories, as you've discovered.
> Given your output above, maybe you want to add the LD_LIBRARY_PATH lines 
> to the zopectl file?

Brilliant! Why doesn't *that* work?! This is crazy! I even added your little 
script and, after it booted, tried running that directly (after stopping Zope) 
and it _still_ didn't work! That makes no sense to me at all! I put together a 
little script, as I stated earlier, that set the env, stopped and started my 
Zope instances (calling on zopectl), and *that* worked, so why doesn't this 
work?? That whole bin dir in Zope is owned by root, so how is running that 
script different than, as root, setting the env? Insane!

No need to miss a message. Get email on-the-go 
with Yahoo! Mail for Mobile. Get started.
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to