I am using a Microsoft Intellimouse Explorer in xwindows on FreeBSD 6.2-RELEASE.

The mouse works correctly (except for the side buttons - I'll worry about those later), but the mouse wheel has some odd behaviour in apps like firefox and thunderbird. Scrolling down works correctly, but scrolling up seems to send a button click as well as a scroll event.


I played around with xev and found that when scrolling up, a button4 event is (correctly) sent, but then any other action sends a button9 and button8 event as well. Scrolling down only sends a button5 event which is correct. Here is the relevant section in xorg.conf:

Section "InputDevice"
       Identifier  "Mouse0"
       Driver      "mouse"
       Option      "Protocol" "auto"
       #Option     "Buttons" "7"
       Option      "Buttons" "5"
       Option      "Device" "/dev/psm0"
       Option      "ZAxisMapping" "4 5"
EndSection

I added the `Option "Buttons" "5"' line hoping to remove the possibility of button 8 and 9 existing, but it didn't seem to work:

[EMAIL PROTECTED] ~]$ xmodmap -pp
There are 9 pointer buttons defined.

   Physical        Button
    Button          Code
       1              1
       2              2
       3              3
       4              4
       5              5
       6              6
       7              7
       8              8
       9              9


Then I tried mapping the button 8 and 9 keys to other buttons, but xmodmap didn't allow it. Also, I'm not running moused if that is significant. Does anyone have any suggestions? I have seen some similar questions on forums and the mailing list archives, but no definitive solutions. Any help would be great.

Thanks,
Jon
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to