After changing my make.conf to list my CPUTYPE as c3 on my

 VIA C3 Nehemiah (999.52-MHz 686-class CPU)

system. I did a cvsup for /usr/src tag=RELENG_6_2 and successfully did a

  make buildworld
  make installworld

I then thought that with my newly compiled tools tuned for the processor in my box, I should rebuild my kernel. I made no changes to my kernel configuration file since my previous successful build a week and a half ago. However, now when I recompile the kernel, I get an internal compiler error from gcc. I rebooted the system and tried to build the kernel again, but got the same error.

The last bit of the make output is

>>> stage 2.3: build tools
cd /usr/obj/usr/src/sys/DOBBY; MAKESRCPATH=/usr/src/sys/dev/aic7xxx/ aicasm make -DNO_CPU_CFLAGS -f /usr/src/sys/dev/aic7xxx/aicasm/Makefile Warning: Object directory not changed from original /usr/obj/usr/src/ sys/DOBBY cc -O -pipe -nostdinc -I/usr/include -I. -I/usr/src/sys/dev/aic7xxx/ aicasm -c /usr/src/sys/dev/aic7xxx/aicasm/aicasm.c
/usr/src/sys/dev/aic7xxx/aicasm/aicasm.c: In function `main':
/usr/src/sys/dev/aic7xxx/aicasm/aicasm.c:308: internal compiler error: Illegal instruction: 4
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
*** Error code 1

Stop in /usr/obj/usr/src/sys/DOBBY.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

The full script of the make is at


the output of dmesg is at


A copy of my make.conf is at


And a copy of my kernel configuration file is at


Any clues or suggestions would be most welcome.


Jeffrey Goldberg                        http://www.goldmark.org/jeff/

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to