On Tue, Mar 13, 2007 at 10:27:27AM -0500, Robert Huff wrote:
> Sergio Lenzi writes:
> 
> >  > >  However, the 4.x binaries want to find libc.so.3, which
> >  > >  doesn't seem to be anywhere around.
> >  > >  
> >  > >  Anyone know the trick to getting this to work?
> >  > 
> >  >  /usr/ports/misc/compat4x ?
> >  
> >  or as a workaround 
> >  add in the /etc/libmap.conf
> >  
> >  libc.so.3                        libc.so
> >  libm.so.3                       libm.so
> >  
> >  ......
> >  that is every shared library it complains add it to 
> >  the /etc/libmap.conf
> 
>       That can work.
>       On the other hand, there's no guarantee the ABI - never mind
> the internal operation - of any function will remain constant across
> a major version bump.  (As far as I know.)

In fact in FreeBSD a version bump is almost always a guarantee that
they are incompatible and you will break some applications by doing
this.

Kris

Attachment: pgpP5h4rGhyeY.pgp
Description: PGP signature

Reply via email to