Im have a network of 4 PCs:
One running RedHat 7.2, one running WinXP, one running Debian and the last
(a laptop) running FreeBSD 4.7-RELEASE.
The RedHat-box acts as a NAT gateway to the internet, and runs a DHCPD to
give out IPs, DNS-servers and such, and here comes the problem. The two
other machines gets all the info properly, but the FreeBSD box does NOT get
DNS-server (it seems), atleast it doesnt update /etc/resolv.conf properly.
ep0 is a PCMCIA 3Com MegaHertz 574B NIC.

/var/log/messages only tells me this:
dhclient: New Network Number:
dhclient: New Broadcast Address:
dhclient: New Hostname:
dhclient: New IP Address (ep0):
dhclient: New Subnet Mask (ep0):
dhclient: New Broadcast Address (ep0):
dhclient: New Routers:

I've tried adding the following to /etc/dhclient.conf (even though manpages
specify that it shouldnt be neccesary):
interface "ep0" {
        request subnet-mask, broadcast-address, time-offset, routers,
domain-name, domain-name-servers, host-name;
        require subnet-mask, domain-name-servers;

Other than all DNS not working, the networking is fine. I've tried touch'ing
/etc/resolv.conf, I've tried adding dummy entries.
Any ideas?

Kindest Regards,

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to