Lubomir Toshev wrote:
Hello,

I am trying to run X11 on a machine with FreeBSD 6.2 and S3 Savage
video card. The installation of X11 was successful. The initial test
is ok, everything seems to function normally. The problem occures when
I try to exit the test with Ctrl-Alt-Backspace. At that moment it
looks like an attempt is made to switch the video mode and the screen
remains black. After some time the monitor goes to power down mode as
if there is no video signal.

By "test" do you mean you just ran the startx script without having a desktop environment installed? Did an xterm (or rather 3 xterms) pop up? If so, usually closing it or typing "exit" at the prompt inside of it should cause the X-Server to shutdown.

As far as killing the server with the keyboard, compare the values in the manpage with those in your configuration file for "man xorg.conf" regarding these options: DontZap, DontVTSwitch, HandleSpecialKeys, and XkbDisable.

It may also be that xkbmap is not loading or cannot find your keyboard map. The next time you start the server, try logging all output somewhere and seeing if there are any errors coming up.
Please, give me a link to a possible solution.


http://linuxreviews.org/man/XF86Config/

http://lists.freedesktop.org/archives/xorg/2004-September/thread.html#3473
(For the above: Read the entire thread starting with Xorg 6.8.1: can't switch VT or resolution)
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to