On 3/20/07, Nikos Vassiliadis <[EMAIL PROTECTED]> wrote:

On Tuesday 20 March 2007 17:01, Eric F Crist wrote:
> On 3/20/07, Eric F Crist <[EMAIL PROTECTED]> wrote:
> >
> > My ISP tells me it should be prefixlen 126, not 128
> >
> > On 3/20/07, Björn König <[EMAIL PROTECTED] > wrote:
> > >
> > > Eric F Crist schrieb:
> > > > [...] I'm performing the configuration as follows:
> > > >
> > > > ifconfig gif0 create
> > > > ifconfig gif0 tunnel <my IPv4 address> <my ISP IPv4 address>
> > > > ifconfig gif0 inet6 alias aaaa:aaaa:a::a bbbb:bbbb:b::b prefixlen
126
> > > >
> > > > When I execute the last command, I get:
> > > > ifconfig: ioctl (SIOCAIFADDR): Invalid argument
> > > >
> > > > [...]
> > >
> > > Use a prefix length of 128 instead of 126.
> > >
> > > Regards
> > > Björn
> >
> >
> Sorry for the top post earlier.  I've eliminated the second IP address
on
> the inet6 ifconfig command, and prefixlen 126 is accepted.  Now I just
get
> no ping replies accross the gif0 interface.  ifconfig shows all the
correct
> information, and netstat -rn shows valid routes.  What am I missing?  I
> *did* have this working at one time this morning, but I tried to get
things
> into rc.conf and haven't been able to get it back up.

There is an errata notice about gif(4)s,
don't know it affects you...

http://www.freebsd.org/releases/6.2R/errata.html


Yes, I saw that, my first post mentions I'm patched and good-to-go.  I've
also tried the work around mentioned, just to be sure.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to