ok thanks.

On 3/31/07, Garrett Cooper <[EMAIL PROTECTED]> wrote:


Kris Kennaway wrote:
> On Sat, Mar 31, 2007 at 06:22:05PM -0300, freenity wrote:
>
>> Hi
>> I wanted to make Nvidia video driver, but because there is no for amd64
I
>> wanted to install the only one that is avaible for freebsd that is
i386, but
>> it throughs this error:
>>
>> ===>  nvidia-driver-1.0.9746 is only for i386, and you are running
amd64..
>> *** Error code 1
>>
>>
>> is there any way to force it to compile under amd64??
>>
>
> No, that's the point :)
>
> Kris
DON'T do that! There are a lot more things under the hood than just
compiling i386 binaries on amd64 and hoping (magically) stuff will just
work. If you want amd64 support you'll have to contact nVidia and get
them to compile / release a driver for the amd64 architecture.

amd64 introduces a lot of new interesting things to the mix in terms of
library locations, primitive type length, etc that can't be resolved
necessarily by just "hoping" it'll compile ;).

-Garrett
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "
[EMAIL PROTECTED]"




--
http://feudaltimes.com.ar - Feudal Times `s webmaster and programer.
http://gamescreators.sourceforge.net - linux games programing community.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to