dbetts wrote:
I have been trying to install amavisd-new, portgrey, and portupgrade. I get the same error on all ports when they try to install dependencies:(this is an example from trying to install the port portupgrade)


=> bdb-0.6.0.tar.gz doesn't seem to exist in /usr/ports/distfiles/ruby.
=> Attempting to fetch from ftp://moulon.inra.fr/pub/ruby/.
fetch: ftp://moulon.inra.fr/pub/ruby/bdb-0.6.0.tar.gz: Can't open data connection => Attempting to fetch from ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/ruby/. fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/ruby/bdb-0.6.0.tar.gz: File unavailable (e.g., file not found, no access)
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/ruby and try again.
*** Error code 1
I have also tried pkg_add and get the error:

ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/ruby/bdb-0.6.0.tar.gz: File unavailable (e.g., file not found, no access)
Is the ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles down?
Or is there a way to install these ports?

Thanks

Not sure why, but this happens on occasion with some ports. What you should do (quickest method) is google the filename listed above, download the file, and save it to /usr/ports/distfiles, then rebuild the port(s). This shouldn't occur with most of your ports though.
-Garrett
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to