Michael,

        I am using a SGI-1600SW (1600 x 1024) and I have found that I must 
specify 
the HorizSync and VertRefresh values in the monitor setting of my xorg.conf  
to get it to work properly, even though all the docs say that it is supported 
using the GLINT R3 driver.  
        Also, I am assuming you are using X 6.9  I have found a large number of 
problems when I tried using X 7.0 on Linux.

Mark

On Monday 02 April 2007 10:12 pm, Michael W. Lucas wrote:
> Hi folks,
>
> I've scoured Google seeking wisdom, and found nothing except hordes of
> Linux users whining about this same problem.  FreeBSD users don't seem
> to have this issue, except for me.  Finally I have no choice but to
> throw myself on your tender mercies.
>
> I've been going nuts trying to get 1440x900 resolution on my new
> Toshiba P105.  Any help anyone could offer would be greatly
> appreciated.  Xorg assures me that the 945GM video card is supported
> by the i810 driver, provided I use the 915resolution program to set
> the resolution before starting X.  I run:
>
> /usr/local/bin/915resolution 3c 1440 900
>
> to add the resolution 1440x900 to the video BIOS.  915resolution -l
> now shows me:
>
> ...
> Mode 3c : 1440x900, 8 bits/pixel
> ...
> Mode 4d : 1440x900, 16 bits/pixel
> ...
> Mode 5c : 1440x900, 32 bits/pixel
> ..
>
> So, in theory 1440x900 should be available to the card.
>
> startx fails without a config file, so I let it create one and tweaked
> in based on gossip, rumour, and innuendo I've uncovered in three days
> of Web searching.  I get something that looks *about* like 1200x768,
> but it's a far cry from 1440x900.
>
> pciconf -lv tells me:
>
> ...
> [EMAIL PROTECTED]:2:0:       class=0x030000 card=0xff311179 chip=0x27a28086
> rev=0x03 hdr=0x00 vendor     = 'Intel Corporation'
>     device     = 'Mobile Integrated Graphics Controller'
>     class      = display
>     subclass   = VGA
> [EMAIL PROTECTED]:2:1:       class=0x038000 card=0xff311179 chip=0x27a68086
> rev=0x03 hdr=0x00 vendor     = 'Intel Corporation'
>     device     = 'Mobile Integrated Graphics Controller'
>     class      = display
> ...
>
> Here's relevant stuff trimmed from my xorg.conf.
>
> --
>
> Section "Module"
>       Load  "extmod"
>       Load  "glx"
>       Load  "dri"
>       Load  "dbe"
>       Load  "record"
>       Load  "xtrap"
>       Load  "type1"
>       Load  "freetype"
>       Load  "i2c"
>       Load  "bitmap"
>       Load  "int10"
> EndSection
>
> ...
>
> Section "Monitor"
>       #DisplaySize      370   230     # mm
>       Identifier   "Monitor0"
>       VendorName   "LPL"
>       ModelName    "0"
> EndSection
>
> Section "Device"
>         ### Available Driver options are:-
>         ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
>         ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
>         ### [arg]: arg optional
>         #Option     "NoAccel"                 # [<bool>]
>         #Option     "SWcursor"                # [<bool>]
>         #Option     "ColorKey"                # <i>
>         #Option     "CacheLines"              # <i>
>         #Option     "Dac6Bit"                 # [<bool>]
>         #Option     "DRI"                     # [<bool>]
>         #Option     "NoDDC"                   # [<bool>]
>         #Option     "ShowCache"               # [<bool>]
>         #Option     "XvMCSurfaces"            # <i>
>         #Option     "PageFlip"                # [<bool>]
>       Identifier  "Card0"
>       Driver      "i810"
>       VendorName  "Intel Corporation"
>       BoardName   "Mobile Integrated Graphics Controller"
>       BusID       "PCI:0:2:0"
> EndSection
>
> Section "Screen"
>       Identifier "Screen0"
>       Device     "Card0"
>       Monitor    "Monitor0"
>       DefaultDepth 24
>       SubSection "Display"
>               Viewport   0 0
>               Depth     1
>               Modes   "1440x900"
>       EndSubSection
>       SubSection "Display"
>               Viewport   0 0
>               Depth     4
>       EndSubSection
>       SubSection "Display"
>               Viewport   0 0
>               Depth     8
>               Modes   "1440x900"
>       EndSubSection
>       SubSection "Display"
>               Viewport   0 0
>               Depth     15
>               Modes   "1440x900"
>       EndSubSection
>       SubSection "Display"
>               Viewport   0 0
>               Depth     16
>               Modes   "1440x900"
>       EndSubSection
>       SubSection "Display"
>               Viewport   0 0
>               Depth     24
>               Modes   "1440x900"
>       EndSubSection
> EndSection
>
> Any ideas, anyone?
>
> Thanks,
> ==ml
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to