Marc,

My machine is working with the kernel that comes with 6.1-STABLE (I archived this good kernel before upgrade the OS to 6.2).
No, I'm not using geom.

Can you send your dmesg.boot and "sysctl -a  kern" output?


Marc G. Fournier wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thiago ...

I'm just curious here, but are you by any chance using geom at all? The only machine I have that seems to be affected like this (where netstat -m doesn't seem to indicate a problem with mbufs) is using gmirror ... the rest all use hardware RAID controllers ...

  Its a long shot, but so far, its the only one I seem to be able to draw :(


- --On Sunday, April 01, 2007 17:07:08 -0300 Thiago Esteves de Oliveira <[EMAIL PROTECTED]> wrote:

I've tried to increase the kern.ipc.nmbclusters value but it worked only when
I changed the kernel to an older one.

netstat -m (Now it's working with the same values.)
-
515/850/1365 mbufs in use (current/cache/total)
512/390/902/65024 mbuf clusters in use (current/cache/total/max)
512/243 mbuf+clusters out of packet secondary zone in use (current/cache)
0/0/0/0 4k (page size) jumbo clusters in use (current/cache/total/max)
0/0/0/0 9k jumbo clusters in use (current/cache/total/max)
0/0/0/0 16k jumbo clusters in use (current/cache/total/max)
1152K/992K/2145K bytes allocated to network (current/cache/total)
0/0/0 requests for mbufs denied (mbufs/clusters/mbuf+clusters)
0/0/0 requests for jumbo clusters denied (4k/9k/16k)
0/0/0 sfbufs in use (current/peak/max)
0 requests for sfbufs denied
0 requests for sfbufs delayed
2759 requests for I/O initiated by sendfile
2982 calls to protocol drain routines

Ethernet adapters
-
em0: <Intel(R) PRO/1000 Network Connection Version - 6.0.5> port
0xec80-0xecbf m em 0xfebe0000-0xfebfffff irq 10 at device 4.0 on pci7
em0: Ethernet address: 00:04:23:c3:06:78
em0: [FAST]
skc0: <3Com 3C940 Gigabit Ethernet> port 0xe800-0xe8ff mem
0xfebd8000-0xfebdbfff  irq 15 at device 6.0 on pci7
skc0: 3Com Gigabit NIC (3C2000) rev. (0x1)
sk0: <Marvell Semiconductor, Inc. Yukon> on skc0
sk0: Ethernet address: 00:0a:5e:65:ad:c3
miibus0: <MII bus> on sk0
e1000phy0: <Marvell 88E1000 Gigabit PHY> on miibus0
e1000phy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX-FDX,
auto

P.S.: I am using the FreeBSD/amd64.

Brian A. Seklecki wrote:
Show us netstat -m on the broken kernel?  Show us your dmesg(8) for
em(4).

TIA,
~BAS

On Fri, 2007-03-30 at 11:13 -0300, Thiago Esteves de Oliveira wrote:
Hello,

I've had a problem with one of my FreeBSD servers, the machine has stopped
its network services and then sent these messages:

-Mar 27 13:00:03 anubis dhcpd: send_packet: No buffer space available
-Mar 27 13:00:26 anubis routed[431]: Send bcast sendto(em0,
146.164.92.255.520): No buffer space available

The messages were repeated a lot of times before a temporary solution. I've
changed the kernel(FreeBSD 6.2) to an older one(FreeBSD 6.1) and since then
it's been working well. What happened?

P.S.: I can give more informations if necessary.


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to