We have a (very) remote FreeBSD 5.5-RELEASE system running on Asus RS120
hardware and historically configured with 2 identical SATA drives using
atacontrol RAID1 and the system installed on ar0.

One of the drives has died, however no identical replacement drive could
be easily sourced at the remote location.

So, attempting to get things back to normal RAID1 operation as quickly as
possible we have tried a same size but non-identical drive and attempted
an atacontrol rebuild. However, this is stuck indefinitely at 0% rebuild
progess.

While I'm aware that some RAID1 mechanisms e.g. CCD seem to insist on
identical disks, the documentation isn't so clear on ATA and I figured it
was worth a try. Does anyone know if it is possible to overcome the
non-identical disk issue and allow ata RAID1 to work again?

I've also considered keeping the current ar0 setup on the single working
disk and setting up a gmirror RAID1 copy on the second disk would work.

Current config info is as follows:

>From atacontrol list:

ATA channel 2:
    Master:  ad4 <WDC WD2000JD-00HBB0/08.02D08> Serial ATA v1.0
ATA channel 3:
    Master:  ad6 <HDT722525DLA380/V44OA9BA> Serial ATA v1.0

>From the permanently going nowhere rebuild output of atacontrol status:

ar0: ATA RAID1 subdisks: ad4 ad6 status: REBUILDING 0% completed

The WDC WD2000JD on ad4 is the functional system drive and orignial member
of the RAID1 array. ad6 is the new "spare" and presumably is completely
blank still at this stage.

I realise that sourcing an identical drive is probably the right (or at
least easy) answer. The original drives (WDC WD2000JD on ad4) are still
available for purchase, just not anywhere near where the machine lives -
so getting a replacement drive would be a logistically difficult and
time-consuming exercise.

Thanks,
JS
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to