At 08:14 PM 4/9/2007, L Goodwin wrote:
Derek Ragona said:

> Go into the SCSI BIOS and reset the SCSI to default values.
> If it still gives the same error on bootup, I would go into the SCSI BIOS and
> low-level format that first drive, and reinstall FreeBSD.
> On the reinstall, I would just do the partioning for that drive, and then install everything. > That way it will run mostly by itself, you can just check on it for the last few prompts of the
> install finishing up.

Derek, I just did the following, expecting that this would fix the glitch:

1) Reset the SCSI BIOS to Host Adapter Defaults: Matches prior configuration exactly.
2) Run a low-level format on SCSI device #0: No errors.
3) Install FreeBSD 6.2 from scratch. Note: I answered Yes to the prompt
"ACPI was disabled during boot. Would you like to disable it permanently?".
    I don't think it will boot if I enable ACPI.

4) Ran "Verify Disk Media" on SCSI ID #0: "Disk Verification Complete"

What else could it possibly be? Are there any other diagnostics I can run?
What do you think of the fact that this machine was booting Windows 2000 from the same
SCSI drive prior to installing FreeBSD 6.2?

In case it matters, all SCSI drives are IBM DNES-309170W ULTRA2-LVD.


One other thing that might be happening is if the geometry of the drive isn't allowing an extended translation because of the age of your hardware, you may need to keep the boot partition, that is the entire boot partition (not talking slices here) within the first 1024 cylinders. In the partition tool in sysinstall you can change the display to show different units, and one of those will be cylinders. The 1024 cylinder limit is from older BIOS translations and if the boot partition extended beyond 1024 the system will give that same error you are getting.

With older hardware you may need to use multiple partitions instead of slices. You can have 4 partitons on a drive (4 is hardcoded in the partition table size and a location) so you can add additional partitions for swap and /usr if you want. Any partitions you use for filesystems like /usr the boot manager will see and offer to boot them. They won't boot of course. Swap partitions are ignored by the boot manager.

Otherwise, I'd suspect it is a problem with the 6.2 you are using then. If you try with a boot within the 1024 (I wouldn't push that to the limit I'd say try like 950 cylinders) then I would try an earlier version such as 6.1 or 6.0.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
MailScanner thanks transtec Computers for their support.

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to