Thanks. My printer is attached straight to the network (RJ-45), but I
check /var/db/pkg, and saw no mention of cups-pdf or cups-pstoraster,
so I am installing those...

I'll try setting up my printer when I get home.

-Jim Stapleton

On 4/22/07, Jared Barneck <[EMAIL PROTECTED]> wrote:
Jim Stapleton wrote:
> I'm trying to print a test page for my printer using cups and I get
> the following error:
> Unsupported format 'application/postscript'!
Funny you should post about this problem... I have an HP Laserjet 5L.
It connects via parallel port to my wifes windows XP box.  I was trying
to point to it and I kept getting that same error.

I only had cups-base installed and no other cups ports.

To attempt to fix it I did the following:

1. I made sure these three ports were installed.

cups-base-1.2.2     The Common UNIX Printing System
cups-pdf-2.4.5      A virtual printer for CUPS to produce PDF files
cups-pstoraster-8.15.4 Postscript interpreter for CUPS printing to
non-PS printers

2. I added the windows box to the host file

3. I restarted cupsd.

4. Deleted the printer and readded it.

It started working.  I am not sure which step fixed it.
> I couldn't find anything when googling with FreeBSD in my search. When
> I took out FreeBSD, I got something for debian referencing lines 103
> and 109 in the config being uncommented to get it to work. 103 in the
> default is blank, 109 is blank except for teh '#'.
> I uncommented this line, and restarted CUPS:
> application/vnd.cups-postscript    application/vnd.cups-raster
> 100    pstoraster
> It didn't fix anything.
> I added this line, and restarted:
> application/postscript    application/vnd.cups-raster    100
> pstoraster
> And I still get the same error.
> I know CUPS worked fine from an install maybe 6 months ago (it had a
> completely different printer setup than now, it wasn't as easy to
> setup, but at least it worked).
> My question
> (1) Anyone know how to fix this issue with the current version
> (cvsup'ed and built today via 'sudo portupgrade -f
> print/cups-pstoraster print/cups-base print/ghostscript-gnu*
> print/ghostscript-gpl*'
> (2) How do I get csup/cvsup to match one port or a group of ports by
> name? I put *default date=2006. in my supfile
> (etc/supfile-ports) and tried:
> sudo csup -i '*cups*' -L 2 /etc/supfile-ports
> sudo csup -i 'print/cups*' -L 2 /etc/supfile-ports
> sudo cvsup -g -i '*cups*' -L 2 /etc/supfile-ports
> sudo cvsup -g -i 'print/cups*' -L 2 /etc/supfile-ports
> and none of the above updated any files according to the output (I
> usually see a list of files updated). Since ports were updated this
> morning, without the date line (so to today's ports layout), I should
> have seens something.
> Thanks,
> -Jim Stapleton
> _______________________________________________
> mailing list
> To unsubscribe, send any mail to

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to