I've encountered three annoying problems since doing the upgrade from
6.1-RELEASE to 6.2-RELEASE using the upgrade option when booting from the
installation CD.  This is on a Dell Inspiron XPS (3.4 GHz P4 w/HTT enabled
and 1 GB of memory).

        1) The ports and packages subsystems are as fragile as ever (no big
           surprise).  I was able to add packages for less than a day before
           it broke.  Sometimes I can still add or delete a package, but
           in at least one case, I can't because pkg_add says that an earlier
           version of the package is already installed, while an attempt to
           remove the earlier version using pkg_delete gets a message saying
           that no such package is installed.  Apparently, pkg_add and
           pkg_delete do not refer to the same indicators of whether a
           particular package is actually installed.  Attempting to build ports
           fails while trying to build dependency ports, which was what led
           to attempt to remove libtool and then add the newer version.  I'll
           try to get a PR together and submitted soon.

        2) I had been eagerly awaiting the new version of snd_emu10k1, which
           is supposed to contain support for the Soundblaster Audigy 2 cards,
           and I was hoping that my Soundblaster Audigy 2 ZS PCMCIA card
           might be included in that support.  Last night I finally added
           snd_driver_load="YES" to /boot/loader.conf and rebooted.  It looked
           good until it correctly identifed the card, at which point it hung.
           After some delay, the machine *powered itself down*.  Trying to
           restart it failed repeatedly before it could complete the hardware
           initialization prior to booting, and it powered itself down each
           time, sometimes turning on the battery light briefly as it did so.
           Eventually, fearing hardware damage, I removed the PCMCIA card,
           after which I was able to boot the installation CD again in order
           to remove the line from /boot/loader.conf.  Unfortunately, the
           6.2-RELEASE installation CD does not allow me to mount the hard
           drive's root file system onto /mnt in order to change the hard
           drive's /boot/loader.conf file the way the 6.1-RELEASE CD did.
           I next tried booting from the hard drive, selecting safe mode--
           which may not have mattered anyway--I think the key was removing
           the sound card, and got to where I could edit the file.  Rebooting
           after that proceeded uneventfully.  Because of the computer's
           thoroughly bizarre response to having the new snd_emu10k1 driver
           active when the sound card was present, I am reluctant to try this
           again to document it well enough to submit a PR.  I haven't yet
           tried the $100 sound card again under Windows XP to find out whether
           it still works. 8-|

        3) I use wmaker as a window manager for X.  Since the 6.2-RELEASE
           upgrade, I seem no longer able to cut/copy + paste anything except
           when doing the operation entirely inside Firefox windows.  I can
           still select the text I want to copy, but I am unable to paste it
           into other windows (e.g., Putty, xterm) or even into the same
           window.

     The first two I don't expect to be able to do anything about, other than
maybe submitting a PR for the first one, but perhaps someone can show me a
way to fix the third one.  Any help would be appreciated.
     Thanks muchly in advance.


                                  Scott Bennett, Comm. ASMELG, CFIAG
**********************************************************************
* Internet:       bennett at cs.niu.edu                              *
*--------------------------------------------------------------------*
* "A well regulated and disciplined militia, is at all times a good  *
* objection to the introduction of that bane of all free governments *
* -- a standing army."                                               *
*    -- Gov. John Hancock, New York Journal, 28 January 1790         *
**********************************************************************
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to