My FreeBSD 5.2.1 server had a 4.5 GB HDD. I decided to upgrade it with a larger drive. I installed a new drive on the second IDE channel which made it ad2, of course, my original drive was ad0. I created a partition, boot loader and matching slices on the new drive. Then I copied the old drive to the new drive. Once finished, I removed the original drive and installed the new one on the primary channel. When I booted up everything appeared normal, but when the system starts to mount "/" it gives no error or warning and just drops to a "Manual mount root specification" prompt. If type "ufs:ad0s1a" it boots up and everything is perfect. This is the same slice "/" was on the old drive as well.


I have tried the following with no success:

Checked /etc/fstab

boot0cfg -v -B ad0

bsdlabel -B ad0s1

tried booting from a cd, going into post install config, fdisk, and set the partition as bootable, it already was.



Since upgrading the hard disk, I have upgraded the system to 5.5 and then to 6.2. This system has been working great for over a week now, just have this boot problem.


--------------

Here is my fstab:

/dev/ad0s1b             none            swap    sw              0       0
/dev/ad0s1a             /               ufs     rw              1       1

--------------

Output from bsdlabel
# bsdlabel ad0s1

# /dev/ad0s1:
8 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  a: 585018626  1048576    4.2BSD     2048 16384 28552
  b:  1048576        0      swap
c: 586067202 0 unused 0 0 # "raw" part, don't edit


--------------

Output from boot0cfg
# boot0cfg -v ad0
#   flag     start chs   type       end chs       offset         size
1   0x80      0:  1: 1   0xa5   1023:254:63           63    586067202

version=1.0  drive=0x80  mask=0xf  ticks=182
options=nopacket,update,nosetdrv
default_selection=F1 (Slice 1)





Thanks,

David
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to