Hi,

I tried to reduce the MTU of a network interface on a remote FreeBSD 6.2 
machine.

So that means changing this line in rc.conf:

ifconfig_bge0="inet xxx.xxx.xxx.xxx netmask 255.255.255.128"

to

ifconfig_bge0="inet xxx.xxx.xxx.xxx netmask 255.255.255.128 mtu 1472"

Of course, there's a real IP address set.

Then, I tried to restart the network interface:

/etc/rc.d/netif restart

which went horribly wrong. I lost connection and wasn't able to reconnect. I 
tried to run this in some 'fallback' script, which automatically should 
restore the old configuration and restarting the network interface again 
after 5 minutes. Even if that failed, it should reboot the machine. But 
somehow the script was aborted, although I ran it in a 'screen' session over 
SSH. So the last resort  was a manual reboot, which started the interface 
with MTU 1472 just fine.

Could someone please point out where I made the mistake?

Thanks in advance,

-- 
Bram Schoenmakers

What is mind? No matter. What is matter? Never mind.
(Punch, 1855)
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to