Andrew Falanga wrote:
> Hi,
> I'm about to launch this computer through the roof!  This tcpdump is
> more finicky than feline when it comes to eating.  What really bugs me
> is that just a couple of days ago I was doing this very same thing
> with no problems.  For some reason, however, I just can't resurrect
> the memory of how the syntax goes.
> I want to capture only the IPv6 UDP traffic from my FreeBSD box to a
> host I'm trying to mount through NFS.  A couple of days ago, I got it,
> but I had to kill that terminal session abnormally and the commands
> aren't in my history.  So, I have something like this,
> tcpdump -v -s 192 -i fxp0 ip6 host remote
> The above works.  However, when I try to modify the command to filter
> out only the UDP traffic, I've tried something like this:
> tcpdump -v -s 192 -i fxp0 ip6 udp host remote
> To which tcpdump complains of syntax errors.  Variations I've tried are:
> tcpdump -v -s 192 -i fxp0 ip6 proto udp host remote
> tcpdump -v -s 192 -i fxp0 udp ip6 host remote

expression primitives have to be AND'd.

tcpdump -v -s 192 -i fxp0 host _remote_ and udp and ip6

> Please help!
Hope this helps,

> Thanks,
> Andy

Pietro Cerutti

PGP Public Key ID:

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to