Hello Howard,

Friday, May 11, 2007, 1:09:01 AM, you wrote:

> Ghirai wrote:
>> Hello list,
>> 
>> Suddenly, the startup scripts for various applications won't work.
>> I have these in /usr/local/etc/rc.d:
>> apache22, ircservices, postgresql, pure-ftpd, unrealircd
>> 
>> When i run any of them without parameters, they give out the parameters.
>> But when i use any of the params, nothing happens.
>> 
>> Starting the binaries themselves (from /usr/local/sbin, etc,
>> depending on the application) works, and the applications
>> themselves work fine.
>> 
>> None of the scripts work, they show the same behavior,
>> and i ran them as root.

> I don't have any of those installed but most of the local rc.d scripts
> need an enable flag in /etc/rc.conf . Take a look at your rc.d scripts
> and see if they need them to.  You can also run these with -x to see 
> what's happening (eg.,  sh -x /usr/local/etc/rc.d/apache22 start)

You were right, i forgot to add the flag in rc.conf.

Thanks for the quick replies everyone.

-- 
Best regards,
Ghirai.

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to