On Friday 11 May 2007 04:00:15 pm you wrote:

> WizLayer <[EMAIL PROTECTED]> escribió: On Friday 11 May 2007 11:23:11 am 
Simon Castillo wrote:

> >
> > Gerard Seibert  escribió: On Fri, 11 May 2007
> > 01:45:47 -0500
> >
> > WizLayer  wrote:
> > > I could be wrong as I haven't used portmanager in a while (and that
> > > was only a short time)...  I believe that by default, portmanager
> > > doesn't update dependencies more than a depth of 1 (maybe two?)
> > > unless you use the -p flag. Then it updates dependencies all the way
> > > back?  A quick 'man portmanager' should verify this as I don't have
> > > it installed anymore.
> >
> > Yes, update your ports tree and then run:
> >
> >  portmanager -u -l -p
> >
> > You can substitute the 'f' flag for the 'p' one if you want to redo the
> > system.
> > 
> > Hi Gerard:
> >
> > I tried your suggestion and I still have the same result.  It updated
> > couple more files, but the error (missing library) is still there.
> >
> > Any other suggestion?
> >
> > Thanks in advance
> >
> > Simon
> Top posting is generally considered rude, just so you know...
> Any rate, your next option is to locate the missing library, figure out
> where your app thinks the library should be, and then ln to it so that your
> app sees the link...
> Any particular reason you're using portmanager (I haven't used it recently,
> but have had bad experiences with it in the past.  I'm one of those who
> prefer portupgrade).  Of course, I'm not saying this is a fault with
> portmanager.  I honestly don't know.  I was just wondering why you were
> using it (ie maybe it's been matured enough that I should check it out
> again).
> Don't know what else to tell you.
> WizLayer
> Hi WizLayer:
> Nope, no particular reason to use portmanager.  I guess I'll one more that
> suffer a bad experience.  I don't see any other solution than re-install
> every thing again.
> Thanks
> Simon
reinstalling everything isn't necessarily a bad thing.  I do it on a regular 
basis on my experiment boxes...  Or are you talking about the whole OS?  That 
would be a bit extreme, I think.

I'm using 6.2s right now and am not having any problems with it at all, and I 
cvsup and portupgrade fairly regular.  Before depopulating pkgdb, try 
installing the portupgrade port, then cvsup, refetch the index file, and run 
your portupgrade -a.  You can list the ports that need upgrading by using 
the 'portversion | grep ">" | more' command.  portupgrade will  _only install 
those listed if you tell it to 'portupgrade -aRrv'   

If the problem still exists, and linking the file doesn't work, then mayhaps a 
reinstall of all the ports is necessary (I just don't see how unless you've 
specifically done something in your build options that put a ripple in the 



Life is better with a BSD.
For more info, www.bsd.org.

Attachment: pgpxQTxTVc3xX.pgp
Description: PGP signature

Reply via email to