Tom Judge a écrit :
Philippe Laquet wrote:

Dear All,

I a trying to get HAVP (it works almost well, great software!) but I also need to use the streaming option and it needs a FS mounted with mandatory locks. I did not found any option with UFS(2) and also tried with ext2fs loaded but the mount_ext2fs does not support "-o mand" ... Any idea?...

My config : FBSD 6-STABLE
HAVP 0.85 (tuned makefile to compile the with STREAM function)

Tried with :
mdconfig -a -t malloc -s32m
mount_ext2fs -o mand /dev/md0 /tmp/havp (the "mand" option is not recognized)

I don't think that FreeBSD has mandatory file locks, I believe that all locks are advisory. I may be wrong but this is what the section on file/descriptor locking in "The Design And Implementation of the FreeBSD Operating System" seemed to suggest, this may have changed since 5.2 tho.


OK - Thanks Tom, I will take a look on it, I think that HAVP was first developped on and for GNU/Linux, that may explain the need of a Mandatory (derived from SysV?) locks... I am currently looking on the source code of HAVP and check is a FreeBSD Patch could be done.

Kind Regards,
_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to