Greetings all,

A few days ago i got very strange problem with my amd64 system.

It is with ASUS A8V motherboard with AMD 64 3200+ and 1G memory.

Last update was on April 17, and now buildworld fails with ICE:

> --------------------------------------------------------------
>>>> Rebuilding the temporary build tree
> --------------------------------------------------------------
> rm -rf /usr/obj/usr/src/tmp
> rm -rf /usr/obj/usr/src/lib32
> mkdir -p /usr/obj/usr/src/tmp/legacy/usr/bin
[...]
> mtree -deU -f /usr/src/etc/mtree/BSD.include.dist  -p 
> /usr/obj/usr/src/tmp/usr/include >/dev/null
> ln -sf /usr/src/sys /usr/obj/usr/src/tmp
> 
> --------------------------------------------------------------
>>>> stage 1.1: legacy release compatibility shims
> --------------------------------------------------------------
> cd /usr/src; MAKEOBJDIRPREFIX=/usr/obj/usr/src/tmp  INSTALL="sh 
> /usr/src/tools/install.sh"  
> PATH=/usr/obj/usr/src/tmp/legacy/usr/sbin:/usr/obj/usr/src/tmp/legacy/usr/bin:/usr/obj/usr/src/tmp/legacy/usr/games:/sbin:/bin:/usr/sbin:/usr/bin
>   WORLDTMP=/usr/obj/usr/src/tmp  MAKEFLAGS="-m /usr/src/tools/build/mk  -m 
> /usr/src/share/mk" make -f Makefile.inc1  DESTDIR=  BOOTSTRAPPING=602109  
> -DNO_HTML -DNO_INFO -DNO_LINT -DNO_MAN -DNO_NLS -DNO_PIC  -DNO_PROFILE 
> -DNO_SHARED -DNO_CPU_CFLAGS -DNO_WARNS legacy
> ===>> tools/build (obj,includes,depend,all,install)
> /usr/obj/usr/src/tmp/usr/src/tools/build created for /usr/src/tools/build
> cd /usr/src/tools/build; make buildincludes; make installincludes
> rm -f .depend
> mkdep -f .depend -a    -I/usr/obj/usr/src/tmp/legacy/usr/include 
> /usr/src/tools/build/dummy.c
> cc -O2 -fno-strict-aliasing -pipe  -I/usr/obj/usr/src/tmp/legacy/usr/include 
> -c /usr/src/tools/build/dummy.c
> building static egacy library
> ranlib libegacy.a
> sh /usr/src/tools/install.sh -C -o root -g wheel -m 444   libegacy.a 
> /usr/obj/usr/src/tmp/legacy/usr/lib
> 
> --------------------------------------------------------------
>>>> stage 1.2: bootstrap tools
> --------------------------------------------------------------
> cd /usr/src; MAKEOBJDIRPREFIX=/usr/obj/usr/src/tmp  INSTALL="sh 
> /usr/src/tools/install.sh"  
> PATH=/usr/obj/usr/src/tmp/legacy/usr/sbin:/usr/obj/usr/src/tmp/legacy/usr/bin:/usr/obj/usr/src/tmp/legacy/usr/games:/sbin:/bin:/usr/sbin:/usr/bin
>   WORLDTMP=/usr/obj/usr/src/tmp  MAKEFLAGS="-m /usr/src/tools/build/mk  -m 
> /usr/src/share/mk" make -f Makefile.inc1  DESTDIR=  BOOTSTRAPPING=602109  
> -DNO_HTML -DNO_INFO -DNO_LINT -DNO_MAN -DNO_NLS -DNO_PIC  -DNO_PROFILE 
> -DNO_SHARED -DNO_CPU_CFLAGS -DNO_WARNS bootstrap-tools
===>> games/fortune/strfile (obj,depend,all,install)
> /usr/obj/usr/src/tmp/usr/src/games/fortune/strfile created for 
> /usr/src/games/fortune/strfile
> rm -f .depend
> mkdep -f .depend -a    -I/usr/obj/usr/src/tmp/legacy/usr/include 
> /usr/src/games/fortune/strfile/strfile.c
> echo strfile: /usr/lib/libc.a /usr/obj/usr/src/tmp/legacy/usr/lib/libegacy.a 
> >> .depend
> cc -O2 -fno-strict-aliasing -pipe  -I/usr/obj/usr/src/tmp/legacy/usr/include 
> -c /usr/src/games/fortune/strfile/strfile.c
> /usr/src/games/fortune/strfile/strfile.c: In function `cmp_str':
> /usr/src/games/fortune/strfile/strfile.c:417: internal compiler error: 
> Segmentation fault: 11
> Please submit a full bug report,
> with preprocessed source if appropriate.
> See <URL:http://gcc.gnu.org/bugs.html> for instructions.
> *** Error code 1
> 
> Stop in /usr/src/games/fortune/strfile.
> *** Error code 1
> 
> Stop in /usr/src.
> *** Error code 1
> 
> Stop in /usr/src.
> *** Error code 1
> 
> Stop in /usr/src.

I tried cleaning /usr/obj, make cleandepend to no avail.
Today i took out Samsung DIMMS an inserted Kingston's.
The same behaviour. Processor and chipset are not overheated.

Any hints?

Igor


> tech00# dmesg
> Copyright (c) 1992-2007 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
>         The Regents of the University of California. All rights reserved.
> FreeBSD is a registered trademark of The FreeBSD Foundation.
> FreeBSD 6.2-STABLE #3: Tue Apr 17 14:42:56 MSD 2007
>     [EMAIL PROTECTED]:/usr/obj/usr/src/sys/NWE
> Preloaded elf kernel "/boot/kernel/kernel" at 0xffffffff806b8000.
> Calibrating clock(s) ... i8254 clock: 1193209 Hz
> CLK_USE_I8254_CALIBRATION not specified - using default frequency
> Timecounter "i8254" frequency 1193182 Hz quality 0
> Calibrating TSC clock ... TSC clock: 2002570778 Hz
> CPU: AMD Athlon(tm) 64 Processor 3200+ (2002.57-MHz K8-class CPU)
>   Origin = "AuthenticAMD"  Id = 0x20ff0  Stepping = 0
>   
> Features=0x78bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2>
>   Features2=0x1<SSE3>
>   AMD Features=0xe2500800<SYSCALL,NX,MMX+,FFXSR,LM,3DNow!+,3DNow!>
>   AMD Features2=0x1<LAHF>
> L1 2MB data TLB: 8 entries, fully associative
> L1 2MB instruction TLB: 8 entries, fully associative
> L1 4KB data TLB: 32 entries, fully associative
> L1 4KB instruction TLB: 32 entries, fully associative
> L1 data cache: 64 kbytes, 64 bytes/line, 1 lines/tag, 2-way associative
> L1 instruction cache: 64 kbytes, 64 bytes/line, 1 lines/tag, 2-way associative
> L2 2MB unified TLB: 0 entries, disabled/not present
> L2 4KB data TLB: 512 entries, 4-way associative
> L2 4KB instruction TLB: 512 entries, 4-way associative
> L2 unified cache: 512 kbytes, 64 bytes/line, 1 lines/tag, 16-way associative
> real memory  = 1073414144 (1023 MB)
> Physical memory chunk(s):
> 0x0000000000001000 - 0x000000000009efff, 647168 bytes (158 pages)
> 0x00000000007b5000 - 0x000000003e169fff, 1033588736 bytes (252341 pages)
> avail memory = 1027780608 (980 MB)
> ACPI APIC Table: <A M I  OEMAPIC >
> APIC: CPU 0 has ACPI ID 1
> MADT: Found IO APIC ID 1, Interrupt 0 at 0xfec00000
> ioapic0: Routing external 8259A's -> intpin 0
> MADT: Interrupt override: source 0, irq 2
> ioapic0: Routing IRQ 0 -> intpin 2
> MADT: Forcing active-low polarity and level trigger for SCI
> ioapic0: intpin 9 polarity: low
> ioapic0: intpin 9 trigger: level
> ioapic0 <Version 0.3> irqs 0-23 on motherboard
> cpu0 BSP:
>      ID: 0x00000000   VER: 0x00050010 LDR: 0x00000000 DFR: 0xffffffff
>   lint0: 0x00010700 lint1: 0x00000400 TPR: 0x00000000 SVR: 0x000001ff
>   timer: 0x000100ef therm: 0x00010000 err: 0x0001000f pcm: 0x00010000
> random: <entropy source, Software, Yarrow>
> kbd: new array size 4
> kbd1 at kbdmux0
> mem: <memory>
> null: <null device, zero device>
> io: <I/O>
> acpi0: <A M I OEMXSDT> on motherboard
> ioapic0: routing intpin 9 (ISA IRQ 9) to vector 48
> acpi0: [MPSAFE]
> pci_open(1):    mode 1 addr port (0x0cf8) is 0x80010014
> pci_open(1a):   mode1res=0x80000000 (0x80000000)
> pci_cfgcheck:   device 0 [class=060000] [hdr=80] is there (id=02821106)
> AcpiOsDerivePciId: bus 0 dev 17 func 0
> AcpiOsDerivePciId: bus 0 dev 17 func 0
> acpi0: Power Button (fixed)
> ACPI timer: 1/1 1/1 1/1 1/1 1/1 1/1 1/1 1/1 1/1 1/1 -> 10
> Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
> acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to