Vince wrote:
Justin Muir wrote:
Hello,

I load the module and I'm not getting the ipw0 device.
If I'm reading the instructions
(damien.bergamini.free.fr/ipw/ipw-freebsd.html)
correctly, I should be able to:

1. load the driver
2. see the ipw0 device 3. load the firmware into the device with ipwcontrol.


The 3945ABG needs the wpi driver (ipw is for 2100 chipset)
Damien's freebsd wpi driver has been discontinued (for some time see
http://kerneltrap.org/node/6497/ .)
The page for the driver currently being developed is
http://www.clearchain.com/wiki/Wpi but sadly
a) the tarballed versions are old and wont compile on -STABLE or
-CURRENT (dont know about 6.2-RELEASE though)
b) Unless you have perforce access you can only download the more recent
development version file by file (from
http://perforce.freebsd.org/depotTreeBrowser.cgi?FSPC=//depot/user/benjsc/wpi)
c) it doesnt work for me anyway ;)

sorry its not better news

regards,
Vince

The if_ipw kernel module loads without errors.

I checked the device/driver under windows and that's
what it's showing - Intel Pro/Wireless 3945ABG, IRQ 17

I checked my dmesg output and there is a network
device with IRQ 17, but it states there is no driver
loaded.

Not sure what I'm doing wrong here....

Any suggestions?


Thx,


jkm

ps - dmesg and uname output attached



      Be smarter than spam. See how smart SpamGuard is at giving junk email the 
boot with the All-new Yahoo! Mail at http://mrd.mail.yahoo.com/try_beta?.intl=ca


------------------------------------------------------------------------

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"


Hi,

I agree with Vince that the latest drivers do not work at least on FreeBSD 6.1 (I'm using PC-BSD 1.3 which is based on 6.1). I tried them all with no luck. But I tried an older version which does, albeit with some error messages. I don't remember where I found it and I don't remember how I installed it (That will teach me to document everything properly!) but please find it attached and good luck!

Ron
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to