Hey,

I'm running a dev server in VMWare (On a WindowsXP host) just to screw
around with some things. Running FreeBSD 6.2-STABLE. VMWare causes the clock
in FreeBSD to be a inaccurate; it loses about 2 hours every 24 hours.

I read the handbook entry on the NTP daemon which automatically syncs the
clock. Previously I was using cron to run ntpdate every 2 hours.

I set NTPd to update using NTP.org's pool servers. Yet it isn't syncing. I
setup NTPd last night. I checked about 20 minutes ago and the time was off
by 2 hours. I shutdown ntpd and ran ntpdate manually, and it updated just
fine.

My logs have only this:
/var/log/messages:May 30 23:04:19 Jupiter ntpd[489]: ntpd 4.2.0-a Mon May 28
23:49:40 EDT 2007 (1)
/var/log/messages:May 30 23:04:19 Jupiter ntpd[489]: no IPv6 interfaces
found
/var/log/messages:May 31 16:41:50 Jupiter ntpd[489]: ntpd exiting on signal
15

The first two came up as soon as I started NTPd. The third one was when I
stopped it. I rebuild world without IPv6 support. I tried adding the -4 flag
to ntpd_flags in /etc/rc.conf as it says in the man page, but NTPd reports
that -4 doesn't exist.

While NTPd is running, I ran "ntpq -np" to display the peers. It did output
the four servers from pool.ntp.org, so it's connecting fine.

My /etc/rc.conf contains:
ntpd_enable="YES"
ntpd_sync_on_start="YES"
ntpd_flags="-p /var/run/ntpd.pid -f /var/db/ntpd.drift -g"

Anyone know how I can fix this? Or should I just go back to running ntpdate
with cron?
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to