(Originally asked on -hardware and -smp but no one seemed to have any
ideas.  Repeating here to the larger group in hopes of some answers. TIA.)


Intel D946GZIS MOBO w/ICH7 SATA-II support
WDC WD2500JS-00NCB1 250G Hard Drive that claims to do 3G/s
Pentium D @ 3.2GHz

In addition to the on-board peripherals, the two available
PCI slots have an Adaptec 2940 U/UW SCSI controller and
a 3Com 3C901 card in them respectively.

Running FBSD 6.2-STABLE as of yesterday.  Kernel is SMP.

I've run into a problem that makes no sense to me and I suspect
is related to how SMP works (or, then again, maybe not):

1) When booting FBSD 6.2, right after the second CPU is started
   the system hangs for about 45 seconds and then proceeds normally.
   This happens with GENERIC-Release, SMP-Stable, and SMP-Release kernels.
   During this wait, the floppy goes active for some reason.  It's
   as if the system is "hunting" for something.

Other strange anomalies I've noted:

2) If I try to boot the 4.11-Release CD, it gets partway through
   the boot and then spits out:

    RTC BIOS diagnostic error 80<clock battery>

  I've replaced the RTC battery and still get the same error.
  I get no such error with 6.2

3) Both the MOBO and drive are SATA-300 rated, but 6.2 insists that
   the drive is running at SATA-150.  I have verified that the drive
   has no jumper forcing it into this mode.

4) I *cannot* get xorg 7.2 to work with the onboard video.
   If I configure it as a VESA video system, all is well.
   If I try to tell it that I am using i810 video, I get this:

         X Window System Version 7.2.0
    Release Date: 22 January 2007
    X Protocol Version 11, Revision 0, Release 7.2
    Build Operating System: FreeBSD 6.2-STABLE i386
    Current Operating System: FreeBSD troll.tundraware.com 6.2-STABLE FreeBSD 
6.2-STABLE #5: Sun Jun  3 00:42:36 CDT 2007     [EMAIL 
PROTECTED]:/usr/obj/usr/src/sys/SMP i386
    Build Date: 30 May 2007
            Before reporting problems, check http://wiki.x.org
            to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
            (++) from command line, (!!) notice, (II) informational,
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Sun Jun  3 13:05:01 2007
    (++) Using config file: "/root/xorg.conf.new"
    (EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
    (EE) I810(0): Failed to allocate framebuffer. Is your VideoRAM set too low 

    Fatal server error:
    AddScreen/ScreenInit failed for driver 0

   This makes no sense given that I have allocated 128M for video memory.

Anyone have ideas on what is going on here?  (I've DAGS and found nothing
like this in the archives.)
Tim Daneliuk     [EMAIL PROTECTED]
PGP Key:         http://www.tundraware.com/PGP/

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to