thanks for the ideas, i tried both of your suggestions...i manually ran the file, and everything worked as i dumped the output to .sh file looks as such:

case "$1" in
        echo "RAILS found start" >> /tmp/test.file
        kldload accf_http >> /tmp/test.file
        mongrel_rails cluster::start -v -C
/usr/local/www/app/config/mongrel_cluster.yml >> /tmp/test.file
        /usr/local/www/app/script/backgroundrb start
        echo "RAILS found stop" >> /tmp/test.file
        mongrel_rails cluster::stop -v -C
/usr/local/www/app/config/mongrel_cluster.yml >> /tmp/test.file
        /usr/local/www/app/script/backgroundrb stop
        echo "Usage: `basename $0` {start|stop}" >&2
        exit 64

and the test.file ended up with this after the reboot:

$cat /tmp/test.file
RAILS found start

the weird part is that the Rails found stop never printed...and im not sure
why the mongrel_rails fails (im assuming that the kldload works fine as it
doesn't print out any error messages if it is successfull)

i guess i will just keep playing with it...

View this message in context:
Sent from the freebsd-questions mailing list archive at

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to