On Thursday June 07, 2007 at 04:59:05 (PM) Josh Tolbert wrote:

> Having successfully completed my update from Xorg 6.9 to Xorg 7.2, I decided
> to install a few things, one of which required devel/bison2 instead of bison.
> Usually, portupgrade -o would handle this for me, but lately it seems like
> portupgrade -o doesn't want to replace ports. Has anyone else noticed this or
> is there a known workaround/fix?
> (15:38:21 <[EMAIL PROTECTED]:~>) $ pkg_info | grep bison
> bison-1.75_2,1      A parser generator from FSF, (mostly) compatible with Yacc
> (15:38:30 <[EMAIL PROTECTED]:~>) $ sudo portupgrade -o devel/bison2 bison
> (15:38:34 <[EMAIL PROTECTED]:~>) $ sudo portupgrade -fo devel/bison2 bison
> --->  Reinstalling 'bison-1.75_2,1' (devel/bison)
> The same problem occurred when I tried to replace ghostscript-gnu with
> ghostscript-gpl as well.
> I'm using portupgrade-devel instead of portupgrade.

Posting two identical questions except for the "Subject", eighteen
minutes apart, to the same list does seem a bit tacky.

Personally, I once tried to use the newer version of bison as opposed
to the (I believe) bison-1.75, caused me grief. Since both versions
cannot co-exist, at least not without quite a bit of user intervention,
I found that I was getting broken dependencies, etc. being reported. I
quickly reverted to the older version. I think, and as usually I am
probably wrong, that only Open Office requires the newer version.

It would be nice if there were a flag that would force the use of the
newer version. It would be a welcome addition. Maybe something like:
WITH-BISON2 that could be used on the command line or placed in the
/etc/make.conf file for instance.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to