On 07/06/07, Josh Tolbert <[EMAIL PROTECTED]> wrote:

Having successfully completed my update from Xorg 6.9 to Xorg 7.2, I decided
to install a few things, one of which required devel/bison2 instead of bison.
Usually, portupgrade -o would handle this for me, but lately it seems like
portupgrade -o doesn't want to replace ports. Has anyone else noticed this or
is there a known workaround/fix?

(15:38:21 <[EMAIL PROTECTED]:~>) $ pkg_info | grep bison
bison-1.75_2,1      A parser generator from FSF, (mostly) compatible with Yacc
(15:38:30 <[EMAIL PROTECTED]:~>) $ sudo portupgrade -o devel/bison2 bison
(15:38:34 <[EMAIL PROTECTED]:~>) $ sudo portupgrade -fo devel/bison2 bison
--->  Reinstalling 'bison-1.75_2,1' (devel/bison)

The same problem occurred when I tried to replace ghostscript-gnu with
ghostscript-gpl as well.

I'm using portupgrade-devel instead of portupgrade.

Confirmed, -o worked as advertised here
before the move to portupgrade-devel and
now does not.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to