Hi all,

I'm using FreeBSD 6.2-RELEASE-p5, with the standard SMP kernel found
in /
usr/src/sys/i386/conf/SMP, when i 'kldload atapicam' i get the following
error message which just makes no sense to me: WARNING - PREVENT_ALLOW
taskqueue timeout - completing request directly xptioctl: put device
in your kernel config file xptioctl: pass driver is not in the kernel

Right after I get this error message, it starts repeating again and
and the system is no more useable.

Then I installed the normal GENERIC kernel without SMP support, and the
same thing happens, same error message. Then i tried to compile "device
atapicam" directly into the kernel, which makes the system hang at boot
time, while recognizing the cdrom.

The standard SMP kernel "includes" the GENERIC kernel in which the line
"device pass" can be found, that means pass must be allready in the

Please have a look at the output from dmesg and kldstat -v here (link)

I searched the web for similar error messages, and found a message
pointing this problem to hald, so i disabled hald to see if that chances
anything. And it did, while 'kldload atapicam' i'm not getting the above
error message anymore, but 'camcontrol devlist' doesnt show anything and
cdrecord -scanbus ends up in the following errormessage: Cdrecord-Clone
2.01 (i386-unknown-freebsd6.2) Copyright (C) 1995-2004 Jÿffffÿffffrg
cdrecord: Error 0. Cannot open SCSI driver. cdrecord: For possible
try 'cdrecord -scanbus'. cdrecord: For possible transport specifiers try
'cdrecord dev=help'. I checked with 'kldstat', and it showed atapicam.

Since my mainboard has just one ide port onboard(rest is S-ATA), i have
use a pcie ide-controller "Promise Technology, Inc. PDC20268 (Ultra100
TX2)" on which my dvdwriter(acd0) is connected to.

Any help or suggestion is really appreciated.

Thanks in advance, greeting


freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to