I just installed a fresh 6.2-RELEASE i386 system last night and was
trying to get cvsup-without-gui installed from ports and was having
some interesting problems.  The install of FreeBSD went flawlessly,
and the system boots without a hitch.

After installing the ports tree, I went and did "make install clean"
in the dir for cvsup-without-gui.  The script appeared to be working
through the requirements just fine too.  It downloaded all necessary
files and was proceeding to the build phase.  I'm not sure in which
package this occurred but the build just died on me.  No errors, just
a hard hang.  Nothing worked.  I could not even Alt+<num> to a
different pseudo terminal.  The system just hard hanged.  I rebooted
and tried the install again with the same result.

I'm wondering if it could be hardware, specifically memory.  I've
never seen a FreeBSD, OpenBSD or Linux (for that matter) hard hang on
program compilation apart from hardware problems.  Also of particular
interest with this machine, is that during startup it takes (no
exaggeration) about 2 minutes for sshd to start (at least, "starting
sshd" is the last line on stdout printed during startup at this
point).  I've never seen a system take that long start sshd, even
slower machines than this one.  On the initial startup, I chalked it
up to the generation of key pairs, but it happened on the second
startup too.

System configuration is as follows:

AMD K6 700mHz
256mb RAM (PC 133)
13gb HDD

I have 384mb of PC 100 memory laying around that I was going to try
and test my theory on, but wanted to consult some of the more
experienced on this forum before going "hog" wild on this.  Just out
of curiosity, what are the impacts of using memory chips of unlike
speeds in the system at the same time?  I've heard, in times past,
that if one does mix memory chips, the slower chips should be used in
the lower priority (i.e. higher numbered) slots.  Is this true, or is
this bogus?

I'm running FreeBSD 6.2 at work on two "lost-leader", no name
"cheap-o" laptops also with 256mb of memory with no problems (granted,
they are Celeron 1.7gHz but still).  I'm even running X with XFCE or
KDE on them.  I'm really suspecting faulty memory.  Oh, by the way,
this is to be a web server therefore, I'm not going to be running any
GUIs by default.  Text based administration only.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to