I've tried some tunnel in FreeBSD box, I started with this URL :

I've two interface in that machine 'wi0' and 'xl0', wi0 link to my IPS
and xl0 link for my local net. My ifconfig output look like:

router# ifconfig -a
        inet netmask 0xfffffff0 broadcast
        inet6 fe80::260:97ff:fedc:f02e%xl0 prefixlen 64 scopeid 0x1
        inet netmask 0xffffffff broadcast
        ether 00:60:97:dc:f0:2e
        media: Ethernet autoselect (10baseT/UTP)
        status: active
lp0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
        inet netmask 0xff000000
faith0: flags=8002<BROADCAST,MULTICAST> mtu 1500
        inet netmask 0xfffffffc broadcast
        inet6 fe80::202:2dff:fe2d:228b%wi0 prefixlen 64 scopeid 0x5
        ether 00:02:2d:2d:22:8b
        media: IEEE 802.11 Wireless Ethernet autoselect (DS/11Mbps)
        status: associated
        ssid terasnet-09 1:terasnet-09
        stationname kumprang
        channel 2 authmode OPEN powersavemode OFF powersavesleep 100
        wepmode MIXED weptxkey 1
        wepkey 1:64-bit
gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
        tunnel inet -->
        inet6 2001:618:4:2000::dde --> 2001:618:4:2000::ddd prefixlen 128
        inet6 fe80::260:97ff:fedc:f02e%gif0 prefixlen 64 scopeid 0x6

I used ipng.org.uk for broke tunnel, so this /etc/tunnel.conf

# Account details

#host and port of tunnel server (5571 non ssl, 5572 ssl)

#interface containing the tunnel endpoint ip and the tunnel interface

#remote tunnel ipv4 endpoint and tunnel ipv6 endpoints
#local_ip=<youip> - Only use this if you have a static address!

I've tunnel in inside interface xl0 ( and I run a
tunnelc like:

router# ifconfig gif0 destroy
router# tunnelc
WARNING: Unable to verify Server Certificate
210 - OK TLS Session Established. DES-CBC3-SHA
200 - Tunnel Server 0.2.1 waiting.
201 - OK Now a password if you please.
202 - OK Password accepted. Welcome budsz
203 - OK Ip updated to
210 - OK If you insist. Bye.
add net default: gateway 2001:618:4:2000::ddd
Tunnel(gif0) created

For ipf.rules and ipf6.rules:

router# cat /etc/ipf.rules
pass in all
pass out all

router# cat /etc/ipf6.rules
pass in all
pass out all

So, I try to ping to xl0:
router# ping6 2001:618:4:2000::dde
PING6(56=40+8+8 bytes) 2001:618:4:2000::dde --> 2001:618:4:2000::dde
16 bytes from 2001:618:4:2000::dde, icmp_seq=0 hlim=64 time=0.54 ms
16 bytes from 2001:618:4:2000::dde, icmp_seq=1 hlim=64 time=0.453 ms
--- 2001:618:4:2000::dde ping6 statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 0.453/0.497/0.540/0.043 ms

If I try to broke gateway:

router# ping6 2001:618:4:2000::ddd
PING6(56=40+8+8 bytes) 2001:618:4:2000::dde --> 2001:618:4:2000::ddd
ping6: sendmsg: No route to host
ping6: wrote 2001:618:4:2000::ddd 16 chars, ret=-1
ping6: sendmsg: No route to host
ping6: wrote 2001:618:4:2000::ddd 16 chars, ret=-1

I try to find in routing table:

$ netstat -r | more

Destination        Gateway            Flags      Netif Expire
::                 localhost.kumprang UGRSc       lo0 =>
default            gif1635.tunnels.ip UGSc       gif0
localhost.kumprang localhost.kumprang UH          lo0
::ffff:     localhost.kumprang UGRSc       lo0
gif1635.tunnels.ip                    UH         gif0
                   link#6             UHL         lo0
fe80::             localhost.kumprang UGRSc       lo0
fe80::%xl0         link#1             UC          xl0
fe80::260:97ff:fed 00:60:97:dc:f0:2e  UHL         lo0
fe80::%lo0         fe80::1%lo0        Uc          lo0
fe80::1%lo0        link#3             UHL         lo0
fe80::%wi0         link#5             UC          wi0
fe80::202:2dff:fe2 00:02:2d:2d:22:8b  UHL         lo0
fe80::%gif0        link#6             UC         gif0
fe80::260:97ff:fed link#6             UHL         lo0
ff01::             localhost.kumprang U           lo0
ff02::             localhost.kumprang UGRS        lo0
ff02::%xl0         link#1             UC          xl0
ff02::%lo0         localhost.kumprang UC          lo0
ff02::%wi0         link#5             UC          wi0
ff02::%gif0        link#6             UC         gif0

I can't understand why it's happen, so finally I ask to this malinglist
because google.com can not help me. would you like explain this?

Thank You for advance.


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to