On Monday 18 June 2007 7:52:55 pm Mark Kirkwood wrote:
> Byron Campbell wrote:
> > On Sunday 17 June 2007 10:23:19 pm Mark Kirkwood wrote:
> >> AFAICS the symbol is defined in:
> >>
> >> /usr/local/lib/xorg/modules/drivers/ati_drv.so
> >>
> >> e.g:
> >>
> >> $ nm ati_drv.so|grep ATIMemoryTypeNames_88800CX
> >> 0000b5c0 D ATIMemoryTypeNames_88800CX
> >>
> >> What does it show on your system (I'm wondering if your
> >> ati drivers have not been upgraded properly).
> >
> > Ah, good point. The output here is:
> >
> > 0000000000e940 D ATIMemoryTypeNames_88800CX
>
> Well - seems to be defined there.... hmmm. not sure why you
> are getting 'undefined symbol' in atimisc_drv.so in that
> case. I am wondering if the problem is tied up with amd64
> specifically - hopefully someone else will have some ideas
> :-).
>
> In the meantime you could hack your xorg.conf to use 'vesa'
> driver and see if you can actually startup X - try adding
> modeline settings in there for your monitor if you still
> get 'out of range' (tho I must say I've *never* needed to
> put them in with Xorg...).
>
> Also worth trying might be borrowing a DVI cable (assuming
> your monitor has a DVI input) and seeing if X works with it
> connected instead of the VGA one.
>
> Cheers
>
> Mark

Thanks for the input Mark. I did a make deinstall / reinstall 
of both xorg-7.2 and xorg-drivers-7.2. 

Xorg -configure no longer reports the "undefind symbol...." 
but I still get a black screen when testing the config, 
with "out of range OSD when using a VGA to monitor cable, and 
just a black screen (no OSD message) with the DVI cable. 
Tried a second monitor also, same results. And under these 
conditions I can't Alt F2 etc. to console, but must hit 
the "reset" for a dirty reboot.

Xorg -configure now reports:

(++) Using config file: "/root/xorg.conf.new"
(WW) RADEON: No matching Device section for instance (BusID 
PCI:1:0:1) found
(**) RADEON(0): RADEONPreInit

Manually doing the config by running xorgcfg -textmode gives a 
different BusID in the xorg.conf file --> BusID PCI:1:0:0 

Andy's xorg.conf is identical to mine,  except for the Horz / 
Vert monitor scan frequencies of course. And I've tried the 
vesa driver with the same blank / black screen results.

I'm also getting a sporadic "stray irq7" kernel message from 
time to time. Something weird is going on, huh?

Booted Knoppix-Live and it runs just fine. Copied its 
xorg.conf detected mode lines into FreeBSD xorg.conf but 
still no luck.

Thanks Andy, Mark for your help. But it looks like it is time 
for plan #2; Reinstall from scratch but no X, cvsup ports to 
latest and then do a fresh install of xorg-7.2. Maybe this 
weekend's project...

Best regards,
Byron 

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to