On 6/21/07, Jonathan Horne <[EMAIL PROTECTED]> wrote:
On Thursday 21 June 2007 09:32:31 Andrew Falanga wrote:
> Hi,
>
> How can one install the xorg meta port for version 6.9 before
> beginning the upgrade to 7.2?  I have already updated my ports tree,
> and I don't think I do one of these numbers any longer:
>
> cd /usr/ports/x11/xorg && make install clean
>
> I then thought about downloading the 6.9 xorg package, but all I found
> on the freebsd  ftp servers was a package for 7.2.  I see in the
> UPDATING file for ports that if one doesn't have the meta port
> installed, they will missout on several sub ports for xorg 7.2.
>
> Andy
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "[EMAIL PROTECTED]"

i think the easiest way will be to set the variable PACKAGESITE to
ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.2-release/All/

(or that of your other favorite mirror)

for bash-like shells,
export
PACKAGESITE=ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.2-release/All/

or csh-like shells,
setenv PACKAGESITE
ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6.2-release/All/

then 'pkg_add -r xorg' and it should grab it.  if not, try naming it by full
package name, 'pkg_add -r xorg-6.9.0'.

good luck,

Thanks for the instructions.  This would have been easier than the
method I was working to use.  I managed to find xorg-6.9.0 under the
directory you mention above ".../ports/i386/packages-6.2-release/..."
and downloaded it.  But, when I did the package add, it wouldn't go
for me because the package dri was missing.  Well, I probably
overlooked it somehow, but I couldn't find the "dri" package on the
ftp server.  Thankfully, a thought dawned on me that perhaps these
packages would exist in the cd's I burned of 6.2-RELEASE.  I was able
to find both packages on that CD (disk 1) and although there was a
slight warning when I did the pkg_add for the dri package (some other
package it requires was of a higher version than it was looking for),
all installed ok and I'm now working through the install to xorg 7.2.

Thanks again,
Andy
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to