Hi,

I'm having a problem trying to get gvim 7.0.224 working. Every time I try to start it I get the following error:


E665: Cannot start GUI, no valid font found|16H|8H|4H|31H

and I get the console vim instead. I think I've messed up my xorg fonts somehow after upgrading to 7.2. I followed all of the steps in /usr/ports/UPGRADING, but I didn't have the xorg metaport installed so I installed it after upgrading. The first time I started it there was an error message that said I needed to run a program in the fonts directory (I forget which one), but I'm pretty sure I didn't fix the module path before running the command. I'm using the terminal in Xfce 4.4.1 to try and start gvim.

Here's part of my xorg.conf (now) in /etc/X11 that seems to be related to fonts:

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"         # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

# This loads the font modules
    Load        "type1"
    Load        "freetype"
#    Load        "xtt"

# This loads the GLX module
#    Load       "glx"
# This loads the DRI module
#    Load       "dri"

EndSection


# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

#    RgbPath    "/usr/local/share/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
#

    FontPath   "/usr/local/lib/X11/fonts/misc/"
    FontPath   "/usr/local/lib/X11/fonts/TTF/"
    FontPath   "/usr/local/lib/X11/fonts/OTF"
#    FontPath   "/usr/local/lib/X11/fonts/Type1/"
    FontPath   "/usr/local/lib/X11/fonts/100dpi/"
    FontPath   "/usr/local/lib/X11/fonts/75dpi/"
    FontPath   "/usr/local/lib/X11/fonts/local/"
#    FontPath   "/usr/local/lib/X11/fonts/Speedo/"
#    FontPath   "/usr/local/lib/X11/fonts/TrueType/"
#    FontPath   "/usr/local/lib/X11/fonts/freefont/"

# The module search path.  The default path is shown here.

    ModulePath "/usr/local/lib/xorg/modules"

EndSection

Any help would be appreciated.

Thanks!
Neil

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to