Lisa Casey wrote:
I am attempting to install FreeBSD 5.3 (because that's the latest distro I have CD's for) on a brand new system with a 80 G harddrive and 2 G RAM.

If you're having problems with 5.3, it might be better to try 6.2 or maybe 5.5 than to spend too much time playing with a version that you're going to have to update immediately before using, anyway.

Note that you can simply burn a new FreeBSD image from the ones on ftp.freebsd.org or the mirrors mentioned in the fine manual... :-)

I boot from Disk 1 of the 5.3 disk set and choose to begin a standard installation. Next is the fdisk utility to partition the drive. The first thing I get is a message which states:

WARNING: A geometry of 155061/16/63 for ad0 is incorrect. Using a more likely geometry. If this geometry is incorrect or if you are unsure whether or not it's correct, please consult the hardware guide in the documentation submenu or use the (G)eometry command to change it now.

Even if I go to bios and use the values bios gives for the harddrive (38309/16/255) I still get the same message about incorrect geometry.

You might try updating your machine's BIOS, if anything is available, and you might try entering the disk configuration settings and try to make sure the BIOS is set to LBA mode rather than C/H/S or some manual geometry.

Usually the default/auto setting ends up in LBA mode, anyway, unless your BIOS is old or flaky.

I can choose OK and get past this. I choose to devote the entire disk to FreeBSD, and install the FreeBSD boot manager. Next I need to partition my drive. The defaults won't do at all (this machine is to be a radius server & mail server and the default size of /var is too small). I chose 2000M for /, 4000M for swap (using 2 x RAM), 200M for /tmp, 20,000M for /usr and the remainder for /var.

Next I chose to install full sources, binaries & docs and to install the Ports collection.

I chose to install from CD then hit OK to start copying files but I get this error:

Unable to find device node for /dev/ad0s1b in /dev. The creation of file systems will be aborted.

ad0s1b is my swap partition. I changed the size of swap to 2000M thinking perhaps it was too large but I get the same error about unable to find device node.....

This implies a problem writing out the partition table. Make sure the IDE cables are OK and that the disk drive and CD-ROM drive have the IDE master/slave setting jumpers properly configured.

You might have a BIOS setting about "boot sector virus protection"; if so, turn that off or your BIOS might have prevented FreeBSD from writing the bootstrap info/MBR out to disk.

You might also try using a DOS or Windows version of FDISK to create a small bootable partition (a Win 98/ME recovery floppy works good for this), and see whether that is bootable. If it is, then try installing FreeBSD to the remainder of the disk space.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to