martinko wrote:
hello list,

i was updating sw configuration of my old computer and towards the end i noticed i couldn't log in on local console other than root. i tried remote ssh using public keys which worked but i found out su(1) to any user except root does not work either. i've no idea how i could possibly manage to "break" my system like this and unfortunately i need to fix it by tomorrow. therefore i would really appreciate your prompt hints as what to check etc.

some more details follow ...

upgrade from 6.0-R to 6.2-R
everything went ok ..
i was doing changes in /etc based on my other computer settings
i was working via ssh(1), therefore i haven't noticed when logging on console stopped working.

what works:
log in via ssh(1) using public/private keys
log in on local console as root
su(1) to root

what doesn't work:
log in via ssh(1) using password
log in on local console as a normal user
su(1) to a normal user (it even doesn't ask for password a throws "sorry")

besides, as root i'm able to change passwords via passwd(1), but it doesn't help and a normal user cannot change their own password (old password check would fail).

i ran vipw(8) and it doesn't seem to me there's something wrong with my files.

any hints pls ??


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to