Michael K. Smith - Adhost wrote:
Hello Martinko:

-----Original Message-----
From: [EMAIL PROTECTED] [mailto:owner-freebsd-
[EMAIL PROTECTED] On Behalf Of martinko
Sent: Saturday, July 07, 2007 4:36 PM
To: freebsd-questions@freebsd.org
Subject: Re: cannot log in via console, cannot su(1), only as root

martinko wrote:
hello list,

i was updating sw configuration of my old computer and towards the
end i
noticed i couldn't log in on local console other than root.  i tried
remote ssh using public keys which worked but i found out su(1) to
user except root does not work either.  i've no idea how i could
possibly manage to "break" my system like this and unfortunately i
to fix it by tomorrow.  therefore i would really appreciate your
hints as what to check etc.

some more details follow ...

upgrade from 6.0-R to 6.2-R
everything went ok ..
i was doing changes in /etc based on my other computer settings
i was working via ssh(1), therefore i haven't noticed when logging on
console stopped working.

what works:
log in via ssh(1) using public/private keys
log in on local console as root
su(1) to root

what doesn't work:
log in via ssh(1) using password
log in on local console as a normal user
su(1) to a normal user (it even doesn't ask for password a throws

besides, as root i'm able to change passwords via passwd(1), but it
doesn't help and a normal user cannot change their own password (old
password check would fail).

i ran vipw(8) and it doesn't seem to me there's something wrong with

any hints pls ??

The normal user would have to be a member of the "wheel" group to use su
at any point.  If your normal user logs in via ssh/console/whatever,
they should be able to run the passwd command to change their own
password.  You wouldn't want them to su to do so.  If you want to test
this, add your normal user to the wheel group, log in again and see if
it works.

I'm not having problem with a password as such. I can change it. I just cannot log in using password as any user apart from root, whether logging locally (console) or remotely (ssh). Users I tried su(1) are of course members of wheel group. su(1) failed before even accepting any password. There's something wrong somewhere and I need to find it, just don't know how. Any ideas pls ??


freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to