Written by Andriy Babiy on 07/16/07 02:52>>
Hi everyone!

$ uname -a
FreeBSD ABC.DEF.com 6.2-STABLE FreeBSD 6.2-STABLE #0: Wed Jul 11 06:07:39 PDT 2007 root@:/usr/obj/usr/src/sys/AMD64 amd64

kdm is configured as a login manager in /etc/ttys.

After upgrade to KDE 3.5.7 and X server 7.2 (that was time consuming, but no errors) I receive an error message on startup: Jul 16 00:13:10 FreeBSD-amd64 kdm-bin[792]: X server "/usr/X11R6/bin/X" cannot be executed Jul 16 00:13:10 FreeBSD-amd64 kdm-bin[789]: X server for display :0 can't be started, session disabled

When I logged in, startkde brings another error message:
xsetroot:  unable to open display ''
Warning: kbuildsycoca is unable to register with DCOP.
kbuildsycoca running...
kdeinit: Aborting. $DISPLAY is not set.
There was an error setting up inter-process communications for KDE. The message returned by the system was:

Could not read network connection list.
/home/andrey/.DCOPserver_FreeBSD-amd64.kde.com_NODISPLAY

Please check that the "dcopserver" program is running!
Reusing existing ksycoca
kbuildsycoca: WARNING: '/usr/local/share/applications/kde/ark.desktop' specifies undefined mimetype/servicetype 'application/x-tbz2'
<...>
A lot of messages of the same nature about undefined mimetype/servicetype.
<...>
xset:  unable to open display ""
xset:  unable to open display ""
xsetroot:  unable to open display ''
startkde: Starting up...
ksplash: cannot connect to X server
xprop:  unable to open display ''
kdeinit: Aborting. $DISPLAY is not set.
Warning: connect() failed: : No such file or directory
ksmserver: cannot connect to X server
ERROR: Couldn't attach to DCOP server!
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...

Interesting, when I issue startx, KDE is up and running.
I ran X -configure, and then X -config /root/xorg.conf.new as root; X server starts properly, so I copied new config to /etc/X11. I assume my problem is KDE related. Errors are about DCOP server, as I can see.
Could anyone help me fix this problem? Thank you in advance!

Andriy
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

# ls -lF /usr/X11R6
lrwxr-xr-x  1 root  wheel  10 Jun 18 08:29 /usr/X11R6@ -> /usr/local

If yours does not look like that, then you forgot to merge /usr/X11R6 into /usr/local, which by the looks of the first message (Jul 16 00:13:10 FreeBSD-amd64 kdm-bin[792]: X server "/usr/X11R6/bin/X" cannot be executed) is exactly what has happened. As of Xorg 7, X11BASE is now /usr/local rather than /usr/X11R6, so the Xorg servers will not be at /usr/X11R6/bin. Read the Xorg 7.2 entry in /usr/ports/UPDATING. Specifically, there is a tool (mergebase.sh) included to make the merge step extremely easy.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to