On Sun, 15 Jul 2007 22:42:22 -0500
Michael Gass <[EMAIL PROTECTED]> wrote:

> On Mon, Jul 16, 2007 at 03:06:47AM +0200, Nikola Lecic wrote:
> > On Sun, 15 Jul 2007 19:15:03 -0500
> > Michael Gass <[EMAIL PROTECTED]> wrote:
> > 
> > > Lowell Gilbert wrote:
> > > 
> > > > Hmm.  I've never heard of any symptoms quite like this.
> > > > A few stabs in the dark:
> > > > What happened if you used no xorg.conf at all?  Did you get the
> > > > same xterm problem?
> > > 
> > > >  Do you have a locale set?
> > > 
> > > Thanks for the response.
> > > 1. If I try to running with no xorg.conf, it just hangs. I think
> > > the equipment is too old for the defaults.
> > > 2. My locale is set to "C"
> > > 3. If I set the DefaultDepth to 1 in Screen, then it works - but
> > > of course there is no color.  If I set the DefaultDepth to either
> > > 4 or 8, then I get the garbled text again.  I do not think it is
> > > the keyboard, as the garbled text happens right at the prompt,
> > > and when I do type, it garbles, but the correct thing happens.
> > > For instance, if I type "xterm" then the charactors are messed
> > > up, but an xterm comes up (again with garbled text).
> > > 4. I tried having X construct a configure file for me (Xorg
> > > -configure), but same problem.
> > 
> > Hello Michael,
> > 
> > What happens if you add
> > 
> >   Option  "XaaNoScanlineImageWriteRect" "true"
> >   Option  "XaaNoScanlineCPUToScreenColorExpandFill" "true"
> > 
> > to the Screen section (try Device too)?
> > 
> > Try also:
> > 
> >   Option  "Accel" "false"
> > 
> > Nikola Lečić
> 
> Nikola,
> 
> Thank you for the response.
> This did not work, but it gives me the idea to try similar
> options.  If you have any other advice, please let me know.

Me personally not very much besides Xaa* options (which could be
deductible to my eyes from your xorg conf/log), but others probably do
have.

However, it remains a bit unclear what those garbled characters
exactly look like. Is the text garbled in xterm only? Or in windows
decoration (you mentioned twm) as well? So:

(1) It could be very useful if you could provide a snapshot;

(2) You may try xfontsel(1) as a useful previewer of the fonts in use;

(3) Try 'xterm -font <font>', list them with xlsfonts(1);

(4) Try to start a new thread on freebsd-x11@ named "Garbled text with
    colour depth > 1 on older vga" -- or something like this -- this
    seems to be a crucial part;

(5) Try asking even on X.org;

(6) Whatever you do, please send a feedback here since this is a very
    interesting issue. :)

Nikola Lečić
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to