On Tue, 17 Jul 2007 08:41:08 -0700 (PDT)
johan Hartono <[EMAIL PROTECTED]> wrote:

> 
> Dear all,
> 
>  
> 
> I was trying to make a working mail server using freebsd5.5-release and 
> courier MTA suites.

(you should move up to 6.x if you can, specially since it's a new installation )

> 
> What I need from this box basically are pop3 server, smtpserver, web admin 
> and webmail.
> 
> I install FreeBSD using &#8216;developer&#8217; canned andpull out 
> &#8216;ports&#8217; packages.
> 
> After the installation, I add these packages using pkg_addcommand in the 
> exact order.
> 
>  
> 
> 'libltdl-1.5.22_2'
> 
> 'libexecinfo-1.1_1.tbz'
> 
> 'mime-support-3.39.1'
> 
> 'pcre-7.1'
> 
> 'm4-1.4.9'
> 
> 'perl-5.8.8'
> 
> 'gmake-3.81_2'
> 
> 'gettext-0.16.1_3'
> 
> 'libiconv-1.9.2_2'
> 
> 'libtool-1.5.22_2'
> 
> 'help2man_1.36.4_1'
> 
> 'P5-gettext-1.05_1'
> 
> 'P5-Net-CIDR-0.11'
> 
> 'sysconftool-0.15'
> 
> 'autoconf-2.59_2'
> 
> 'automake-1.9.6_1'
> 
> 'pkg-config-0.21'
> 
> 'glib-2.12.12_2'
> 
> 'gamin-0.1.8_1'
> 
> 'courier-authlib-base-0.59.3'
> 
> 'courier-0.54.0'
> 
>  
> 
> Every time I try to check the installation using showmodulescommand, I got 
> this message
> 

where is this command 'showmodules' from ? 

> 
> &#8220;/libexec/ld-elf.so.1: Shared object"libstdc++.so.5" not found, 
> required by "showmodules"&#8221;

I'm running 6.2-STABLE and I have libstdc++ as part of the base OS:

/usr/lib/libstdc++.so.5

I don't know whether 5.5 had libstdc++.so.5 - you can check in /usr/lib/ to see 
what version is there. I think the problem stems from the fact that you used 
binary packages (pkg_add -r) rather than building from source via the ports 
system. Other than upgrading the OS to 6.x, you can try to see if those 
packages you need are included in the 5.5 CD . Or build from source.

> 
>  
> 
> Can anyone point out what sins I have done badly and how towork around this 
> problem?
> 
>  
> 
> I&#8217;m very sorry for my poor language since English isnot my native 
> language.

your English is fine :)

> 
>  
> 
> I very appreciate any help you could give me.
> 
>  
> 
> Best regards
> 
>  
> 
> Johan Hartono
> 
> 
>        
> ---------------------------------
> Choose the right car based on your needs.  Check out Yahoo! Autos new Car 
> Finder tool.
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "[EMAIL PROTECTED]"


_________________________
{Beto|Norberto|Numard} Meijome

Which is worse: ignorance or apathy?
Don't know. Don't care.

I speak for myself, not my employer. Contents may be hot. Slippery when wet. 
Reading disclaimers makes you go blind. Writing them is worse. You have been 
Warned.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to