Dear ALL,
I am an older newbie trying to set up an old HP Office Jet R60 on my office computer running
FreeBSD 6.2 Stable with the Generic kernel. I followed excellent how to by Daniel Steinbrook (I am trying to use HPLIP since the printer is listed as a fully functional even Linux printing is recommending HPLIP for this printer) except the part about customizing kernel since my printer has a parallel port(I assume that part was relevant only for USB printers so I left kernel GENERIC). Unfortunately when I run hp-setup utility the printer is not detected. However printer is detected by OS as you can see from
[root@ ~]# dmesg
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
       The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-STABLE-200706 #0: Sun Jun  3 14:20:02 UTC 2007
   [EMAIL PROTECTED]:/usr/obj/usr/src/sys/SMP
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(TM)2 CPU 4300 @ 1.80GHz (1799.98-MHz 686-class CPU)
 Origin = "GenuineIntel"  Id = 0x6f2  Stepping = 2
 AMD Features=0x20000000<LM>
 AMD Features2=0x1<LAHF>
 Cores per package: 2
real memory  = 1064894464 (1015 MB)
avail memory = 1032892416 (985 MB)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
cpu0 (BSP): APIC ID:  0
cpu1 (AP): APIC ID:  1
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <NEC > on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_perf0: <ACPI CPU Frequency Control> on cpu0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
cpu1: <ACPI CPU> on acpi0
acpi_perf1: <ACPI CPU Frequency Control> on cpu1
acpi_throttle1: <ACPI CPU Throttling> on cpu1
acpi_throttle1: failed to attach P_CNT
device_attach: acpi_throttle1 attach returned 6
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82945G (945G GMCH) SVGA controller> port 0x8800-0x8807 mem 0xcfd00000-0xcfd7ffff,0xd0000000-0xdfffffff,0xcfd80000-0xcfdbffff irq 16 at device 2.0 on pci0
agp0: detected 7932k stolen memory
agp0: aperture size is 256M
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pci3: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0
pci2: <ACPI PCI bus> on pcib2
pci2: <network, ethernet> at device 0.0 (no driver attached)
uhci0: <UHCI (generic) USB controller> port 0x9000-0x901f irq 20 at device 29.0 on pci0
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0x9400-0x941f irq 17 at device 29.1 on pci0
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <UHCI (generic) USB controller> port 0x9800-0x981f irq 18 at device 29.2 on pci0
usb2: <UHCI (generic) USB controller> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3: <UHCI (generic) USB controller> port 0xa000-0xa01f irq 19 at device 29.3 on pci0
usb3: <UHCI (generic) USB controller> on uhci3
usb3: USB revision 1.0
uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0xcfdffc00-0xcfdfffff irq 20 at device 29.7 on pci0
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: <Intel 82801GB/R (ICH7) USB 2.0 controller> on ehci0
usb4: USB revision 2.0
uhub4: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
pcib3: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci1: <ACPI PCI bus> on pcib3
fwohci0: <VIA Fire II (VT6306)> port 0xc400-0xc47f mem 0xcfef7800-0xcfef7fff irq 21 at device 3.0 on pci1
fwohci0: OHCI version 1.10 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:11:d8:00:00:dc:32:ee
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:11:d8:dc:32:ee
fwe0: Ethernet address: 02:11:d8:dc:32:ee
fwe0: if_start running deferred for Giant
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: BUS reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
ral0: <Ralink Technology RT2561S> mem 0xcfef8000-0xcfefffff irq 21 at device 9.0 on pci1
ral0: MAC/BBP RT2561C, RF RT2527
ral0: Ethernet address: 00:0e:2e:c4:7c:dc
pci1: <multimedia, audio> at device 10.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH7 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 31.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
atapci1: <Intel ICH7 SATA300 controller> port 0xb800-0xb807,0xb400-0xb403,0xb000-0xb007,0xa800-0xa803,0xa400-0xa40f irq 17 at device 31.2 on pci0
ata2: <ATA channel 0> on atapci1
ata3: <ATA channel 1> on atapci1
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
acpi_button0: <Power Button> on acpi0
fdc0: <floppy drive controller (FDE)> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
ppbus0: <Parallel port bus> on ppc0
ppbus0: IEEE1284 device found /NIBBLE/ECP
Probing for PnP devices on ppbus0:
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
Timecounter "HPET" frequency 14318180 Hz quality 2000
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse Explorer, device ID 4
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
pmtimer0 on isa0
orm0: <ISA Option ROM> at iomem 0xcb000-0xcbfff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
acd0: DVDR <LITE-ON DVDRW LH-18A1P/GL0C> at ata0-slave UDMA66
ad4: 152627MB <WDC WD1600JS-00NCB1 10.02E02> at ata2-master SATA150
SMP: AP CPU #1 Launched!
Trying to mount root from ufs:/dev/ad4s1a
g_vfs_done():acd0[READ(offset=32768, length=2048)]error = 5
audigyls0: <AudigyLS> port 0xc800-0xc81f irq 22 at device 10.0 on pci1
g_vfs_done():acd0[READ(offset=32768, length=2048)]error = 5
drmsub0: <Intel i945G>: (child of agp_i810.c) on agp0
info: [drm] AGP at 0xcfd00000 0MB
info: [drm] Initialized i915 1.5.0 20060119
stray irq7

Running as a root user I see that hp-setup utility expect to find parallel port device

I do not have /dev/parport0 in /dev/  as you can see
[pedja@ /dev]$ ls
acd0            dri             kbd0            psm0            ttyv3
acpi            dsp             kbd1            ptyp0           ttyv4
ad4             dsp0            kbdmux0         ptyp1           ttyv5
ad4s1           dsp1            klog            ptyp2           ttyv6
ad4s1a          dsp2            kmem            ptyp3           ttyv7
ad4s1b          dsp3            log             ptyp4           ttyv8
ad4s1c          dsp4            lpt0            random          ttyv9
ad4s1d          dsp5            lpt0.ctl        rdvd            ttyva
ad4s1e          dsp6            mdctl           sndstat         ttyvb
ad4s1f          dsp7            mem             stderr          ttyvc
agpgart         dsp8            mixer           stdin           ttyvd
apm             dsp_ac3         mixer0          stdout          ttyve
ata             dsp_mmap        net             sysmouse        ttyvf
atkbd0          dsp_multich     net1            ttyd0           urandom
bpf0            dvd             net2            ttyd0.init      usb
bpsm0           fd              net3            ttyd0.lock      usb0
console         fd0             net4            ttyp0           usb1
consolectl      fido            network         ttyp1           usb2
ctty            fw0             nfs4            ttyp2           usb3
cuad0           fw0.0           nfslock         ttyp3           usb4
cuad0.init      fwmem0          null            ttyp4           xpt0
cuad0.lock      fwmem0.0        oss             ttyv0           zero
devctl          geom.ctl        pci             ttyv1
devstat         io              ppi0            ttyv2

so I tried manually to specify the device not as /dev/ppc0 (but ppc0 is also not in /dev also I do not have /dev/ppc0) I also tried /dev/lpt0 as a device node since I can get printer reacting on lptest > /dev/lpt0. Unfortunately it prints only one line of codes instead of whole page. I was not playing enough with LP in hope of being able to do HPLIP

Could anybody tell me what am I doing so wrong and give me some kind of directions? Sorry for this simple question.

Predrag Punosevac
Department of Mathematics
University of Arizona

I tried to use CUPS but it seems to me that cups expects printer to be detected as USB or network printer. ( I am messing up something big time with the parallel ports). All I have done was from the root account (I will set permissions latter). My computer is set up to run as a free standing Desktop so the host name is something generic.

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to