Chad Perrin wrote:
> On Thu, Aug 02, 2007 at 02:35:35AM -0600, Chad Perrin wrote:
>> So I tried installing GnuPG on a FreeBSD 6.2-RELEASE system.  It doesn't
>> work without pinentry installed.
>> Okay, I can handle that.  No big deal.  Apparently GnuPG 2.x requires a
>> separate utility for password handling now.  No big deal.  I run
>> portinstall pinentry.
>> At this point, I notice something very, very odd: pinentry won't install
>> because of a problem with Qt.
>> Why the heck would GnuPG ultimately depend on Qt in any way?
> Okay . . . so I should have looked a little harder at the pinentry ports
> available before sending this email to the list.  Apparently there are
> three different versions.  I'm still curious about a couple of things,
> though:
>   1. Why is Qt the default for the nonspecific security/pinentry port?
>   2. Why start a separate, external application for getting the
>   passphrase at all?

I'm not sure, but here's output from my system (default config):

$ cd /usr/ports/security/gnupg
$ make pretty-print-run-depends-list pretty-print-build-depends-list
This port requires package(s) "curl-7.16.1_1 dirmngr-0.9.7_2
gettext-0.16.1_3 libgcrypt-1.2.4_1 libgpg-error-1.5 libiconv-1.9.2_2
libksba-1.0.1_1 openldap-
client-2.3.37 pth-2.0.7" to run.
This port requires package(s) "curl-7.16.1_1 gettext-0.16.1_3
gmake-3.81_2 libassuan-1.0.1 libgcrypt-1.2.4_1 libgpg-error-1.5
libiconv-1.9.2_2 libksba-1.0.1_1 openldap-client-2.3.37 pth-2.0.7" to build.

No pinentry dependency, no such port installed, too:

$ pkg_info -IX "gnupg|pinentry"
gnupg-1.4.7_1       The GNU Privacy Guard
gnupg-2.0.4         The GNU Privacy Guard



Karol Kwiatkowski   <karol.kwiat at gmail dot com>
OpenPGP 0x06E09309

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to