My new USB mouse (a Logitech G5) works fine both in the console (with moused) and under X (both with moused and directly)... For the most part... However, once in a while it just dies (the lights indicating the DPI setting on top and the lights underneath it goes off and it stops responding). Since, according to the ehci man page, the USB 2.0 driver is quite buggy, I tried disabling it, but the problem didn't go away. I've also tried connecting the mouse to different USB connectors without luck.

Every time it happens I get two lines in the /var/log/messages file:

Aug  6 01:03:50 trapper kernel: usb1: host controller process error
Aug  6 01:03:50 trapper kernel: usb1: host controller halted

Now for my questions:

Does anyone have any suggestions as to what causes this?
The mouse itself?
The USB host controllers (then all four controllers on my motherboard are faulty)?
Buggy USB driver (if that is the case, both ehci and uhci are buggy)?
Any other possibilities, that I haven't considered?

I'd apprectiate any help, since this annoys the hell out of me.



Rolf Nielsen
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to