On Wed, 29 Jan 2003, Joe Marcus Clarke wrote:

> On Wed, 2003-01-29 at 20:47, William Palfreman wrote:
> > I've just used portupgrade to upgrade from mozilla 1.0 to 1.2.1.  This
> > is what I get:
> >
> > $ mozilla
> > No running window found.
> > Segmentation fault
> >
> > This is on 4.6.2-p6 on a k6-2 with 512Mb of ram (and compiled with k6
> > optimisations).  Is this my fault (or a minor fault to do with my setup)
> > or is the port broken?  It worked fine before.
>
> You really shouldn't complain unless you're tried things without k6
> optimizations.  Also, there isn't enough information to go on here to
> determine a root cause.  The port is not broken.  It does work for quite
> few people.
>
> What I recommend is first trying with the standard CFLAGS (-O -pipe).
> If it still fails, try building with -DWITHOUT_XFT defined, and see if
> that helps.  If it still fails, you will need to use gdb to analyze the
> crash to see what's going on.  We will also need to see the list of
> other packages installed on your machine.
>
        I second the without k6 optimizations idea , I've tried it with
        varying CFLAGS options and any -m causes it to build fine but
        mozilla and many of the built programs can't do much but segfault.
        (On many different CPU types, amd and intel).

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to