Hello,

I've got a Compaq nx7400 running on 6.2-STABLE with Xorg 7.2.  Despite
my best efforts, I'm unable to get the screen into 1680x1050
resolution.  I have followed the instructions in the handbook but the
issue appears to be getting /dev/agpgart recognized.

Here's some relevant data...

host% kldstat
Id Refs Address    Size     Name
 1   20 0xc0400000 729b34   kernel
 2    1 0xc0b2a000 597c     vesa.ko
 3    1 0xc0b30000 1d684    linux.ko
 4    1 0xc0b4e000 129e0    snd_hda.ko
 5    2 0xc0b61000 23e38    sound.ko
 6    1 0xc0b85000 16db0    agp.ko
 7    1 0xc0b9c000 5d6b0    acpi.ko

/etc/X11/xorg.conf
Section "Module"
        snip
        Load  "dri"
        snip
EndSection

Section "Monitor"
        #DisplaySize      330   210     # mm
        Identifier   "Monitor0"
        VendorName   "LPL"
        ModelName    "1279"
        Modeline     "1680x1050"  122.00  1680 1712 1776 1904  1050
1051 1054 1066 -hsync -vsync
        Option       "DPMS"
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "i810"
    VendorName  "Intel Corporation"
    BoardName   "Mobile 945GM/GMS/940GML Express Integrated Graphics
Controller"
    BusID       "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     24
        Modes     "1680x1050"
    EndSubSection
EndSection

/var/log/Xorg.0.log
snip
(II) I810(0): VESA BIOS detected
(II) I810(0): VESA VBE Version 3.0
(II) I810(0): VESA VBE Total Mem: 7872 kB
(II) I810(0): VESA VBE OEM: Intel(r) 82945GM Chipset Family Graphics
Chip Accelerated VGA BIOS
(II) I810(0): VESA VBE OEM Software Rev: 1.0
(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
(II) I810(0): VESA VBE OEM Product: Intel(r) 82945GM Chipset Family
Graphics Controller
(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) I810(0): Integrated Graphics Chipset: Intel(R) 945GM
(--) I810(0): Chipset: "945GM"
(--) I810(0): Linear framebuffer at 0xE0000000
(--) I810(0): IO registers at addr 0xF4400000
(==) I810(0): Write-combining range (0xf4400000,0x80000) was already
clear
(II) I810(0): 2 display pipes available.
(II) I810(0): detected 7932 kB stolen memory.
(II) I810(0): Kernel reported 0 total, 0 used
(II) I810(0): I830CheckAvailableMemory: 0 kB available
(WW) I810(0): /dev/agpgart is either not available, or no memory is
available for allocation.  Using pre-allocated memory only.
(II) I810(0): Monitoring connected displays enabled
(--) I810(0): Pre-allocated VideoRAM: 7932 kByte
(--) I810(0): VideoRAM: 7932 kByte
(==) I810(0): video overlay key set to 0x101fe
(**) I810(0): page flipping disabled
(==) I810(0): Using gamma correction (1.0, 1.0, 1.0)
(II) I810(0): BIOS Build: 1305
(==) I810(0): Device Presence: disabled.
(==) I810(0): Display Info: enabled.
(II) I810(0): Broken BIOSes cause the system to hang here.
          If you encounter this problem please add
         Option "DisplayInfo" "FALSE"
(II) I810(0): Display Info: CRT: attached: FALSE, present: TRUE, size:
(1280,1024)
(II) I810(0): Display Info: TV: attached: FALSE, present: TRUE, size:
(1024,768)
(II) I810(0): Display Info: DFP (digital flat panel): attached: FALSE,
present: FALSE, size: (0,2059)
(II) I810(0): Display Info: LFP (local flat panel): attached: TRUE,
present: TRUE, size: (1680,1050)
(II) I810(0): Display Info: Second (second CRT): attached: FALSE,
present: FALSE, size: (0,2059)
(II) I810(0): Display Info: TV2 (second TV): attached: FALSE, present:
FALSE, size: (0,2059)
(II) I810(0): Size of device LFP (local flat panel) is 1680 x 1050
(II) I810(0): No active displays on Pipe A.
(II) I810(0): Currently active displays on Pipe B:
(II) I810(0):   LFP (local flat panel)
(II) I810(0): Lowest common panel size for pipe B is 1680 x 1050
(==) I810(0): Display is using Pipe B
(--) I810(0): HW Cursor disabled because it needs agpgart memory.
(--) I810(0): Maximum frambuffer space: 7784 kByte
(II) I810(0): VESA VBE PanelID read successfully
(II) I810(0): PanelID returned panel resolution : 1680x1050
     to the Device section of your XF86Config file.
snip
(II) I810(0): Supported additional Video Mode:
(II) I810(0): clock: 122.0 MHz   Image Size:  331 x 207 mm
(II) I810(0): h_active: 1680  h_sync: 1712  h_sync_end 1776
h_blank_end 1904 h_border: 0
(II) I810(0): v_active: 1050  v_sync: 1051  v_sync_end 1054
v_blanking: 1066 v_border: 0
(II) I810(0):  LGPhilipsLCD
(II) I810(0):  LP154W02-B1K5
(II) I810(0): EDID (in hex):
(II) I810(0):   00ffffffffffff00320c791200000000
(II) I810(0):   000f0102802115780abca59554528c27
(II) I810(0):   23505400000001010101010101010101
(II) I810(0):   010101010101a82f90e0601a10402040
(II) I810(0):   13004bcf100000190000000000000000
(II) I810(0):   00000000000000000000000000fe004c
(II) I810(0):   475068696c6970734c43440a000000fe
(II) I810(0):   004c503135345730322d42314b3500b2
(II) I810(0): Printing DDC gathered Modelines:
(II) I810(0): Modeline "1680x1050"  122.00  1680 1712 1776 1904  1050
1051 1054 1066 -hsync -vsync
(--) I810(0): A non-CRT device is attached to pipe B.
    No refresh rate overrides will be attempted.
(--) I810(0): Maximum space available for video modes: 7784 kByte
snip
(II) I810(0): Monitor0: Using hsync range of 60.00-66.32 kHz
(II) I810(0): Monitor0: Using vrefresh value of 60.00 Hz
(II) I810(0): Not using mode "1680x1050" (no mode of this name)
(II) I810(0): 21992 kBytes additional video memory is required to
    enable tiling mode for DRI.
(II) I810(0): 11240 kBytes additional video memory is required to
enable DRI.
(II) I810(0): Disabling DRI.
(--) I810(0): Virtual size is 1280x1024 (pitch 1280)
(**) I810(0):  Built-in mode "1280x1024"
(**) I810(0): Display dimensions: (330, 210) mm
(**) I810(0): DPI set to (98, 123)


So all I get out of this flat panel is 1280x1024, which distorts the
shape horribly because of the different aspect ratio.

Any hints, clues, pointers are very welcome!


-- 
Regards,
Doug

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to