On Fri, 31 Jan 2003 20:31:00 +1100, Peter Jeremy <[EMAIL PROTECTED]> wrote:

I've recently installed the latest version of opera from ports and
can't get it to start. Have used a couple of older versions of opera
without problems.

Starting with an unmodified opera installation, and no .netscape or
.opera directories, running opera brings up the license window. When
I agree to the license, opera dies with:

INTERNAL ERROR on Browser End: Could not load libjavaplugin_oji.so: linking error=Cannot open "/home/peter/.netscape/java/lib/libjavaplugin_oji.so"

System error?:: No such file or directory

The only libjavaplugin_oji.so I can find is
/usr/local/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so
and when I link it to /home/peter/.netscape/java/lib/libjavaplugin_oji.so
the error message changes to:

INTERNAL ERROR on Browser End: Could not load libjavaplugin_oji.so: linking error=/home/peter/.netscape/java/lib/libjavaplugin_oji.so: Undefined symbol "PR_NewMonitor"

I had (an admittedly older version of) jdk1.3.1 loaded previously.

Any suggestions on how I can get this to work?

- Deinstall the port.

- Download the (static Qt) Linux .tgz from Opera.com, tar -xzvf in a convenient directory, and follow the instructions.

Native version from ports seems to choke on Java and plugins, while the Linux port hadn't been updated since August the last time I looked.

Jud




To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to