I've since updated my ports tree again with the same error, so even though portupgrade says " ! lang/php5 (php5-5.2.3_1) (Makefile broken)" I think it's more likely that something else is wrong.

Are there other things I might try? The DSO apache docs seem to be based on someone compiling by hand without the ports tree or something similar. I think it's something simple I'm missing but I don't really have much of a clue.

Thanks for any help!

Anthony

On Aug 27, 2007, at 9:15 AM, Anthony Philipp wrote:

Thanks for the quick response. I thought I had tried that link
earlier and it hadn't worked. I must have mistyped something.

In any case I was running "portupgrade -aRR" in an attempt to update
my system. While running it quit with this error. I reupdated my
ports tree to see if that was the issue, and tried again, but got
the same error.

Thanks for your help!

Anthony

On Mon, Aug 27, 2007 at 10:00:02AM -0400,
Bob Johnson <[EMAIL PROTECTED]> wrote:

http://httpd.apache.org/docs/2.2/dso.html

What is it that you are actually trying to accomplish? What was the
command that resulted in these errors?

- Bob


On 8/27/07, Anthony Philipp <[EMAIL PROTECTED]> wrote:
Hi,

When I searched for DSO modules I found this page:
http://httpd.apache.org/docs/1.3/dso but it doesn.t seem to have a similar page for the 2.2.x series of Apache. Am I hunting down the correct path? I also checked /usr/ports/UPDATING but unable to find anything of relevance
there. I.ve included the error below. Any help is appreciated.

Regards,

Anthony


--->  Cleaning out obsolete shared libraries
[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 848 packages
found (-0 +1) . done]
** Makefile possibly broken: lang/php5:
        /usr/local/sbin/apxs: not found
        "/usr/ports/Mk/bsd.apache.mk", line 278: warning:
"/usr/local/sbin/apxs -q MPM_NAME" returned non-zero status
        /usr/local/sbin/apxs: not found
        "/usr/ports/Mk/bsd.apache.mk", line 278: warning:
"/usr/local/sbin/apxs -q MPM_NAME" returned non-zero status
        php5-5.2.3_1
        : Your apache does not support DSO modules

---> Skipping 'security/php5-mcrypt' (php5-mcrypt-5.2.3_1) because a requisite package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force) ---> Skipping 'www/punbb' (punbb-1.2.15) because a requisite package
'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
---> Skipping 'converters/php5-iconv' (php5-iconv-5.2.3_1) because a requisite package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
--->  Skipping 'textproc/php5-ctype' (php5-ctype-5.2.3_1) because a
requisite package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force) ---> Skipping 'graphics/php5-gd' (php5-gd-5.2.3_1) because a requisite
package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
---> Skipping 'net/php5-ldap' (php5-ldap-5.2.3_1) because a requisite
package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
---> Skipping 'textproc/php5-xml' (php5-xml-5.2.3_1) because a requisite
package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
---> Skipping 'www/php5-session' (php5-session-5.2.3_1) because a requisite
package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
---> Skipping 'ftp/php5-curl' (php5-curl-5.2.3_1) because a requisite
package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
--->  Skipping 'databases/php5-mysql' (php5-mysql-5.2.3_1) because a
requisite package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force) ---> Skipping 'devel/php5-pcre' (php5-pcre-5.2.3_1) because a requisite
package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
** Detected a package name change: gpdf (graphics/evince) -> 'evince'
(graphics/evince)
** No need to upgrade 'gpdf-2.10.0_5' (>= evince-0.8.3). (specify -f to
force)
---> Skipping 'textproc/php5-simplexml' (php5-simplexml-5.2.3_1) because a requisite package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force) ---> Skipping 'devel/php5-spl' (php5-spl-5.2.3_1) because a requisite
package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
---> Skipping 'textproc/php5-dom' (php5-dom-5.2.3_1) because a requisite
package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
--->  Skipping 'security/php5-mhash' (php5-mhash-5.2.3_1) because a
requisite package 'php5-5.2.3_1' (lang/php5) failed (specify -k to force)
** Listing the failed packages (*:skipped / !:failed)
        ! lang/php5 (php5-5.2.3_1)      (Makefile broken)
        * security/php5-mcrypt (php5-mcrypt-5.2.3_1)
        * www/punbb (punbb-1.2.15)
        * converters/php5-iconv (php5-iconv-5.2.3_1)
        * textproc/php5-ctype (php5-ctype-5.2.3_1)
        * graphics/php5-gd (php5-gd-5.2.3_1)
        * net/php5-ldap (php5-ldap-5.2.3_1)
        * textproc/php5-xml (php5-xml-5.2.3_1)
        * www/php5-session (php5-session-5.2.3_1)
        * ftp/php5-curl (php5-curl-5.2.3_1)
        * databases/php5-mysql (php5-mysql-5.2.3_1)
        * devel/php5-pcre (php5-pcre-5.2.3_1)
        * textproc/php5-simplexml (php5-simplexml-5.2.3_1)
        * devel/php5-spl (php5-spl-5.2.3_1)
        * textproc/php5-dom (php5-dom-5.2.3_1)
        * security/php5-mhash (php5-mhash-5.2.3_1)
---> Packages processed: 7 done, 825 ignored, 15 skipped and 1 failed


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions- [EMAIL PROTECTED]"


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to