> I haven't figured out the proper way myself, but the problem is that the
> defaults you set at top, override the rc.conf variables, because they don't
> exist yet. What I do is move load_rc_config before setting defaults. General
> order becomes:
> name=foo
> rcvar=`set_rcvar`
> load_rc_config ${name}
> foo_default=${foo_default:-"default value"}
> run_rc_command "$1"
>
> Seems to work, maybe I'll figure out the proper way once I finish reading:
> http://www.freebsd.org/doc/en_US.ISO8859-1/articles/rc-scripting/index.html

Thanks.

Putting this before anything else butt he #!/bin/sh and the intro
comments "worked" but spat out some errors.
========================================
name=akpop3d
rcvar=`set_rcvar`
load_rc_config ${name}
========================================
[EMAIL PROTECTED] /usr/local/etc/rc.d]# ./akpop3d start
set_rcvar: not found
load_rc_config: not found
Starting akpop3d.
========================================


So, I tried putting the `. /etc/rc.subr` before that, but it didn't
even start the server (processed with no errors, and a ps -A showed no
server)


At least I have something that *works* now, even if it spews errors. Thank you.

Also, if you reply, could you please reply-all? Sorry, I have this
list in digest mode due to volume, and I can't do a proper reply that
keeps thread information without having a normal copy.

Thanks,
-Jim Stapleton
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to